[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#70428: marked as done (PM2865U3 has problems during debian install)

Your message dated 02 Sep 2000 15:02:36 -0400
with message-id <oag0ni7h2r.fsf@arroz.fake>
and subject line Bug#70428: DPT controller
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Darren Benham
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 28 Aug 2000 12:27:26 +0000
>From jasonm@hammer.tool.net Mon Aug 28 07:27:26 2000
Return-path: <jasonm@hammer.tool.net>
Received: from hammer.tool.net [::ffff:] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 13TO0c-0004As-00; Mon, 28 Aug 2000 07:27:26 -0500
Received: from jasonm by hammer.tool.net with local (Exim 3.12 #1 (Debian))
	id 13TO0b-0005cQ-00; Mon, 28 Aug 2000 08:27:25 -0400
From: Jason Mesker <jasonm@hammer.tool.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: PM2865U3 has problems during debian install
X-Reportbug-Version: 1.1
X-Mailer: reportbug 1.1
Date: Mon, 28 Aug 2000 08:27:25 -0400
Message-Id: <E13TO0b-0005cQ-00@hammer.tool.net>
Delivered-To: submit@bugs.debian.org

Package: boot-floppies
Version: 2.2.16
Severity: important

I am trying to install Debian 2.2 on a new machine with a PM2865U3 controller.  I downloaded a new kernel source 2.2.17, patched it with the DPT controller driver and recompiled the kernel.  I put the kernel in place of the default kernel on the rescue.bin disk.  The version of boot-floppies is:

This disk uses Linux 2.2.17
    (from kernel-image-2.2.17_2.2.17pre6-1)

The error is very non helpfull on finding the problem, on tty3 I get repeated "Open error".  This error starts up as soon as the system boots up, even on the opening screen.  From what I have seen it looks like tty3 is a tail -f of /var/log/messages.  There are no other error messages that I have ever encountered.  It appears that the error messages are coming from dbootstrap becuase it looks like the error messages stop when I kill it, of course it is respawned quickly so I am still not 100% for sure about dbootstrap being the exact problem.

Also the ramdisk is not mounted rw, I have to manually mount -o remount rw / before I can continue the install process.  Also the drives go *very* slow, example, takes around 15 mins to mke2fs on 3 4 gig Raid 5 drives.  

Also the compact version of the bootdisks do not contain the driver for the card as the driver isn't installed in the stock kernel yet for this card.  I will be getting the email address of DPT for Adam Di Carlo as he requested.  Thanks.

-- System Information
Debian Release: woody
Architecture: i386
Kernel: Linux hammer 2.2.15 #1 Thu Jun 22 09:36:29 EDT 2000 i586

Versions of packages boot-floppies depends on:
ii  ash                     0.3.7-2          NetBSD /bin/sh                    
ii  bison                   1:1.28-5         A parser generator that is compati
ii  cslatex                 1.2.1            LaTeX for Czech/Slovak typesetting
ii  cspsfonts               0.2.1            Support for Czech and Slovak Type1
ii  debhelper               2.1.4            helper programs for debian/rules  
ii  debiandoc-sgml          1.1.43           DebianDoc SGML DTD and formatting 
ii  dpkg-awk                1.0.0            Gawk script to parse /var/lib/dpkg
ii  dpkg-dev                1.6.14           Package building tools for Debian 
ii  file                    3.28-1           Determines file type using "magic"
ii  flex                    2.5.4a-7         A fast lexical analyzer generator.
ii  gawk                    1:3.0.4-4        GNU awk, a pattern scanning and pr
ii  gcc                     1:2.95.2-14      The GNU C compiler.               
ii  gettext                 0.10.35-15       GNU Internationalization utilities
ii  libc6-pic [glibc-pic]   2.1.3-10         GNU C Library: PIC archive library
ii  libgd1g-dev             1.7.3-0.1        GD Graphics Library (development v
ii  libi18n-langtags-perl   0.13-1           Perl module for dealing with RFC17
ii  libnewt-dev             0.50.8-1         Developer's toolkit for newt windo
ii  libpaperg               1.0.3-13         Library for handling paper charact
ii  libpopt-dev             1.5-0.1          lib for parsing cmdline parameters
ii  libwww-perl             5.48-1           WWW client/server library for Perl
ii  m4                      1.4-10           a macro processing language       
ii  make                    3.79.1-1         The GNU version of the "make" util
ii  makedev                 2.3.1-44         Creates special device files in /d
ii  man-db                  2.3.17-2         Display the on-line manual.       
ii  perl-5.004 [perl5]      5.004.05-6       Larry Wall's Practical Extracting 
ii  perl-5.005 [perl5]      5.005.03-7.1     Larry Wall's Practical Extracting 
ii  pointerize              0.4              Internationalization utilities, ba
ii  recode                  3.5-1            Character set conversion utility. 
ii  rsync                   2.4.3-1          fast remote file copy program (lik
ii  slang1-pic              1.4.1-1          The S-Lang programming library, sh
ii  tetex-bin               1.0.7+20000807-1 teTeX binary files                
ii  tetex-extra             1.0.2+20000804-1 extra teTeX library files         
ii  zlib1g-dev              1:1.1.3-9        compression library - development 

Received: (at 70428-done) by bugs.debian.org; 3 Sep 2000 00:33:35 +0000
>From adam@onshore.com Sat Sep 02 19:33:35 2000
Return-path: <adam@onshore.com>
Received: from relay05.netaddress.usa.net [::ffff:] 
	by master.debian.org with smtp (Exim 3.12 1 (Debian))
	id 13VNj4-0001A8-00; Sat, 02 Sep 2000 19:33:34 -0500
Received: (qmail 19549 invoked from network); 2 Sep 2000 19:02:19 -0000
Received: from unknown (HELO arroz.fake) (postfix@
  by relay05.netaddress.usa.net with SMTP; 2 Sep 2000 19:02:19 -0000
Received: by arroz.fake (Postfix, from userid 421)
	id 9ED4B93802; Sat,  2 Sep 2000 15:02:36 -0400 (EDT)
Sender: apharris@arroz.fake
To: Jason Mesker <jasonm@tool.net>
Cc: 70428-done@bugs.debian.org
Subject: Re: Bug#70428: DPT controller
References: <39ABD3E0.7A6332C8@tool.net> <oa8zteyhz3.fsf@arroz.fake> <39AD1AC3.DAAD8F5F@tool.net>
From: Adam Di Carlo <adam@onshore.com>
Date: 02 Sep 2000 15:02:36 -0400
In-Reply-To: Jason Mesker's message of "Wed, 30 Aug 2000 14:31:31 +0000"
Message-ID: <oag0ni7h2r.fsf@arroz.fake>
Lines: 18
User-Agent: Gnus/5.0803 (Gnus v5.8.3) Emacs/20.7
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Delivered-To: 70428-done@bugs.debian.org

Jason Mesker <jasonm@tool.net> writes:

> Actually when I took steps a little further it looks like I have a buggy
> version of potato-pre which is causeing the mount of the ramdisk to be
> read only from the rescue disks.  I tried just a normal install and it
> did the same thing.  I downloaded new disks and the problem is fixed. 
> Sorry about that and thanks for all you concern.  You are a very
> valuable person for the Debian project because of your strong desire to
> help people fix their problems....  I can only hope to be of as much
> help for the Debian project myself one day.  This bug can be closed. 
> Thanks again.

Thanks for the kind words.  Closing the bug.  Please feel free to open
a bug on kernel-image-2.2.17-compact if there is a way for Debian to
provide support for this driver natively.

.....Adam Di Carlo....adam@onShore.com.....<URL:http://www.onShore.com/>

To UNSUBSCRIBE, email to debian-boot-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: