[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CALL FOR HELP : debian boot floppies 2.2.15 on apus still not ok.

Sven LUTHER wrote:

> Everything works fine, but when i come to the step where i would normally do
> :
>   * install os kernel & modules
> i give the corrct place in the requester, and dbootstrap tries to loop mount
> the rescue.bin image to fetch the kernel and the modules, and fail.

Confirm that. ("Roger that" ;)

Messages from VT 3 I consider relevant:

running cmd 'mount -r -t ext2 /dev/loop0 /floppy'
Mounting /dev/loop0 on /floppy failed: invalid argument

Looks like it tries to use /dev/loop0 as a fake floppy drive and fails.

> I then tried testing by hand, with :
> $ mount -r -t vfat -o loop=/dev/loop0 resceu.bin /mnt
> Mounting rescue.bin on /mnt failed : block device required

It has just worked for me with just '-o loop', and I notice that it seems to
be mounted from /dev/loop1 (df output).

> $ mount -r -t vfat -o loop=/dev/loop0 resceu.bin /mnt
> And see if it can be mounted ...

It works if I omit the '=/dev/loop0' , and now on the second try (after
getting back to the installer main menu) df shows /dev/loop0 .

So the problem must be elsewhere, any ideas?


Software is like sex; it's better when it's free  - Linus Torvalds
Earthling Michel Dänzer (MrCooper)  \  CS student and free software enthusiast
Debian GNU/Linux (powerpc,i386) user \   member of XFree86, Team *AMIGA*, AUGS

Reply to: