[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#63286: problems installing debian on old laptop

Package: boot-floppies
Version: (http://www.debian.org/releases/slink/i386/lowmem.bin
architecture:  i386
model:         Kenitec NP-204, 486 laptop
memory:        3712 KB (3.625 MB)
scsi:          none
cd-rom:        none
network card:  none
pcmcia:        none
hard drive:    124 MB IDE, Type 47
bios:          American Megatrends, (c)1990,  Ver. SX&SLC-25.03
bios serial #: 31-0100-ZZ1462-00111111-070791-HT18C-H
bios date:     07/07/91
Processor:     80486
Numeric Processor: None
Base Memory:   640 KB
Ext. Memory:   3072 KB
Serial Ports:  3F8,2F8
Parallel Port: 378

Warning: This bug report contains a TON of information, in the hopes
that someone, somewhere, will be able to help me! :)

1. On my main machine, wrote lowmem.bin to a floppy using:
        dd if=lowmem.bin of=/dev/fd0
2. Booted laptop using floppy:
        A. Normal BIOS boot stuff, memory test, system information
        B. Message "SYSLINUX 1.42 1998-12-05 Copyright (C) 1994-1998 H.
Peter Anvin"
           appears, then a few seconds later...
        C. A nice "Welcome to Debian GNU/Linux 2.1!" screen appears,
informing me
           that "This disk uses Linux 2.0.36 (from
kernel-image-2.0.36_2.0.36_3)" and
           to "Press <F1> for help, or <ENTER> to boot!"
3. I hit enter to boot linux.
4. Here's what I see:
boot: <I press enter here>
Loading lowmemrd.bin....
Loading linux..............
Uncompressing Linux...done.
Now booting the kernel

---> less than 1 second after the "Now booting the kernel" message
appears, my system reboots itself, and (unless I'm quick and pull the
floppy out) I'm presented with the same "boot:" prompt.  Hitting enter
again only repeats the above process, resulting in another reboot.

CMOS Settings:  (I have included all settings, for the sake of
Basic CMOS Setup:
Date                        : 4/29/2000
Time                        : 22 : 11 : 57
Daylight saving             : Enabled
Hard disk C: type           : 47 = USER TYPE, 934 cyl, 16 head, 0 WPcom,
0 LZone, 17 Sect
Hard disk D: type           : Not Installed
Floppy drive A:             : 1.44 MB, 3 1/2"
Floppy drive A:             : Not Installed
Primary Display             : VGA/PGA/EGA (other choices ->
boot-time/CMOS error)
Keyboard                    : Installed
Advanced CMOS Setup:
Typematic Rate Programming  : Disabled
Typematic Rate Delay (msec) : 500
Typematic Rate (Chars/Sec)  : 15
Above 1 MB Memory Test      : Enabled (have tried Disabled, still fails)
Memory Test Tick Sound      : Enabled
Hit <DEL> Message Display   : Enabled
Hard Disk Type 47 RAM Area  : 0:300 (other choice is "DOS 1KB" ->
boot-time/CMOS error)
Wait For <F1> If Any Error  : Enabled
System Boot Up Num Lock     : Off
Numeric Processor Test      : Enabled
Floppy Drive Seek At Boot   : Enabled (have tried Disabled, still fails)
System Boot Up Sequence     : A:, C:
System Boot Up CPU Speed    : High
Internal Cache Memory       : Enabled  (have tried Disabled, still
Fast Gate A20 Option        : Disabled (have tried Enabled, still fails)
Password Checking Option    : Disabled
Adaptor ROM Shadow C000,16K : Disabled
Adaptor ROM Shadow C400,16K : Disabled
Adaptor ROM Shadow E000,64K : Disabled
System  ROM Shadow F000,64K : Disabled
--> Have tried with all "ROM Shadow" options enabled, system runs much
faster, still fails
384 KB Memory Relocation    : Disabled (have tried Enabled ->
boot-time/CMOS error)

Incidentally, the system was running MS-DOS6.x/Win3.x without problems
before I reformatted the hard drive (as FAT using Partition Magic) and
began the Debian install.

I'd *really* love to get Debian running on this old dog.  Any ideas are
very much appreciated, and if there's any other info I can provide, feel
free to ask...


  - jonathan.

Reply to: