[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#62530: boot-floppies: Lilo only boot still not working

Nils Rennebarth <nils@ipe.uni-stuttgart.de> writes:

> On Sat, Apr 22, 2000 at 11:45:34PM -0400, Adam Di Carlo wrote:
> > Ok, I think I figured this out. I haven't tested it all the way, but
> > when lilo is redirected to install on extended partition because root
> > is a logical partition, we need to fall back to install-mbr/activate.

> Why?
> The "It's a logical partition therefore lilo must go into the
> extended partition" only applies to non-lilo-MBR cases.

Not according to the lilo documentation.

> If the user wants lilo as MBR simply remove the check. I assure you
> (and have done it many times) that even on a fresh disk, fresh
> install, no MBR before
> boot=/dev/hda
> root=/dev/hda5
> image=/vmlinuz
>   label=linux
> just works.

Oh, that's interesting.  Maybe it depends on the bios.  Maybe the lilo
documentation is out of date.  I've CC'd the lilo maintainer for

Anyhow, you can refile a bug (wishlist) to this effect, if you like.
Bug62530 was RC and has been solved.

.....Adam Di Carlo....adam@onShore.com.....<URL:http://www.onShore.com/>

Reply to: