[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.2.7 install report

>>>>> "Ross" == Ross Boylan <RossBoylan@stanfordalumni.org> writes:

    Ross> OK, if I get a chance I will duplicate, elaborate, check old bug reports
    Ross> and file new ones.  Until then...

 Thank you for taking the time to do this.  It is very helpful.  If
 you have the time, inclination, and facilities for doing so, perhaps
 you would like to work with the current CVS version as a tester /

    Ross> I think the most significant new (at least to me) problem was the failure
    Ross> of ppp to load.  Also, I got hung up trying to get packages off the CD, but
    Ross> that may reflect oddities of my setup.

 The PPP problem was also reported by someone else.  I think it's the
 .unconfigured file in /lib/modules/$(uname -r)/pcmcia causing `depmod
 -a' to fail.  Did you notice any error messages about not being able
 to read an ELF header?

    Ross> I booted off diskettes for the initial install.  I pointed it at the hard
    Ross> drive for base2_2.  Unlike my previous attempts, this worked.  This may be
    Ross> from my slavish adherence to the file hierarchy, as advised in earlier
    Ross> posts.  Or perhaps something is fixed.

 It must have offered a menu where you can have it scan or have it let
 you specify the exact directory to find those things in.

    Ross> I did notice that when the installation routine asked for paths and I told
    Ross> it to auto-search, it came up with /mountpoint/path
    Ross> where mountpoint was some local mount point, and path was the "regular"
    Ross> path.  Could this be the source of some problems?  Nobody is going to enter
    Ross> a path with /mountpoint at the start, and this might cause any hand entered
    Ross> path to fail.

 I made some changes that fix a few problems with the path entry
 dialog.  The directory browser should always work now.  (reminds me;
 I noted something yesterday in this that I should fix soon; when the
 path is "", it ought to be set to "/" for the dir browser.)

    Ross> Things went smoothly until driver selection.  Here are the drivers, in the
    Ross> order I loaded them.
    Ross> nfs -- failed with warnings about unresolved symbols in (from?) sunrpc.o
    Ross> ntfs, vfat, awe_wave--all fine
    Ross> joy_creative -- failed.  Could be my hardware, or a conflict with awe_wave

    Ross> Can anyone tell me if I need the lp driver?  I have a parallel port with a
    Ross> printer on it.
    Ross> ppp--fails.  Many unresolved symbols /lib/module/2.2.14/net/ppp.o.  This is
    Ross> critical for me.
    Ross> Done with driver configuration.

 Deja vu...  You reported this elsewhere, right?  Same person?

    Ross> I then got dumped automatically into network configuration as if I were on
    Ross> a decent network!  I've already reported this as a bug for 2.2.6; it's
    Ross> still there for 2.2.7.  The message refers to eth0 and asks about DHCP or
    Ross> B?TP.  Though I have an ethernet card in the machine it isn't connected,
    Ross> and this was the wrong path for me.  I hit enter mostly to get through this
    Ross> section.

 Like I said, it ought to offer a menu...  I don't know if the code
 supports this or not yet; I've not looked through netconfig.c yet, to
 be honest.

    Ross> On to setting up the base system.
    Ross> After responding to the shadow password question it asked where to get the
    Ross> deb's (not the way the question was phrased).  I said to use the CD.  It
    Ross> asked for a name for the CD.  I typed it in, hit enter, and nothing happened.

    Ross> Installation was completely hung at this point.  Well, the other consoles
    Ross> worked, and I could have killed it--but it didn't go forward.  ^c and ^d
    Ross> had no effect.

 This sounds like the same thing it does when you try to use the NFS
 method when there is not NFS support in the kernel.  It hangs waiting
 for a mount command to finish.  If you switch to vt2 and use `ps',
 you'll likely see that.  This all needs to be looked into.  There
 probably ought to be a timeout to kill the attempting mount after a
 period of however long.  NFS should not be offered if there's no NFS
 in the kernel.  It needs testing!  I'm not sure it works even when
 you insmod the NFS module.

    Ross> This is obviously bad behavior.  On the other hand, my CD was extremely
    Ross> nonstandard: I burned it with assorted debs and a  packages file which was
    Ross> right for the whole archive, but not too good for the CD.

 That might do it.  Look into the `debian-cd' package or CVS modules.
 It does a pretty good job.  Just be sure you set the SIZELIMIT right
 or you'll end up with a disk 1 image that's too big for a CD.  It
 might take 2 or 3 tries.

    Ross> Also, I really need apt behavior, which I think was an
    Ross> option (I want it to look for packages in a variety of
    Ross> places).

 It should have asked if you want to add another `apt' source.

Reply to: