[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

progress report on debian/powerpc/apus boot-floppies.

Hello, ...

after another build of the debian/powerpc/apus boot floppies (from modified
2.2.4). I noticed the following problems. Some of them might actually be
solved already since then.

Anyway :

pb1 : the Blizzard powerup scsi detection is not working for me, thus no
access to the scsi disks. Will have to fix the kernel-image used.

pb2 : i tried including amiga-fdisk, but it depends on libncurses4 and
libreadlineg2, thus not being included. Will try to build a static
amiga-fdisk, or a version that don't depend on these libraries. What do the
m68k/amiga folk do about this ?

pb3 : When i call partition the harddisk, cfdisk is called, and not
amiga-fdisk, like it should be. cfdisk don't know anything about amiga
partitioned harddisks. There is a minor problem also on
scripts/rootdisk/fdisk-powerpc which becomes /sbin/fdisk, but even fixing this
don't seem to influence the "partition the harddisk" menu option. Strange
since a manual call to fdisk finds the correct amiga-fdisk (or don't find it).
There is something i don't understand here, what is libfdisk for in the
busybox, i can read the partition correctly (with the menu option view the
partition table) but not set it. If the busybox has a working fdisk, why is
fdisk included in the boot floppies ?

pb4 : When first configuring the network, and choosing the no option (for ppp)
there is an error message : "Error writing to /root/ppp"

pb5 : When installing the kernel, it searches for disks-1.44/rescue.bin, which
should be resc1440apus.bin. Anyway, would be better to search for the
linuxapus binary and the drivers.tgz file, or even only the driver.tgz, since
we don't have lilo, and a kernel on the ext2 partition is only a waste of
space. Is it possible to change that menu option to "install the kernel
modules" or something such, and go searching for drivers.tgz only, for
architectures not supporting lilo or similar ?

pb6 : there are a lot of menu choices that don't make sense on my
arch/subarch. This include the precedent Install OS kernel & modules, but also
"make linux bootable directly from harddisk", "make boot floppy", "eject
floppy disks" and "configure pcmcia support". Would be nice to add a
"configure the bootstrap system" or something such, who would mount a bootable
affs partition (for apus or m68k/amiga), and do the appropriate stuff to make
it work. How can i modify this stuff ? it is in utilities/dbootstrap, right ?

pb7 : There is arch specific stuff in scripts/rootdisks. But, at least for
powerpc, we have one rootdisk per subarch, which makes sense, since on apus,
mac-fdisk, pcmcia_cs and eject are not needed, while amiga-fdisk seems to be.
Would it not be better if we could differenciate between subarches, or is the
plan to have a common rootdisk per arch. It should be possible, now that we
removed the kernel from the rootdisk.

pb8 : MAX_DISKNAME_LEN is still not defined, but i guess it is in cvs. Will
have to get the cvs version. How do i do that (i had a mail with it, but lost
my mail archive yesterday ...:())

Ok, thats all for now, i will upload the bootfloppies this afternoon so the
apus people can test them more, get the cvs version, and try to solve the
amiga-fdisk problem.



Reply to: