[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [FYI] lilo can not parse compact

Here's the lilo.conf file which goes with the error message.  Note that
this is basically as generated by the dbstrap (?) initial configuration.
Also note there is no linear, which I note was linked to problems with
compact in some earlier versions:

# Generated by liloconfig

# Specifies the boot device

Specifies the device that should be mounted as root.
# If the special name
CURRENT is used, the root device is set to the
# device on which the root
file system is currently mounted. If the root
# has been changed with  -r ,
the respective device is used. If the
# variable ROOT is omitted, the root
device setting contained in the
# kernel image is used. It can be changed
with the rdev program.

# Enables map compaction:
# Tries to merge
read requests for adjacent sectors into a single
# read request. This
drastically reduces load time and keeps the map
# smaller. Using COMPACT is
especially recommended when booting from a
# floppy disk.

Install the specified file as the new boot sector.
# If INSTALL is omitted,
/boot/boot.b is used as the default.

# Specifies the
number of _tenths_ of a second LILO should
# wait before booting the first
image.  LILO
# doesn't wait if DELAY is omitted or if DELAY is set to

# Specifies the location of the map file. If MAP is
omitted, a file /boot/map is used.


# Specifies the VGA text
mode that should be selected when
# booting. The following values are
recognized (case is ignored):
#   NORMAL  select normal 80x25 text mode.
 EXTENDED  select 80x50 text mode. The word EXTENDED can be
abbreviated to EXT.
#   ASK  stop and ask for user input (at boot time).
 <number>  use the corresponding text mode. A list of available modes
can be obtained by booting with  vga=ask  and pressing


# If you
have another OS on this machine (say DOS),
# you can boot if by
uncommenting the following lines
# (Of course, change /dev/hda2 to wherever
your DOS partition is.)
# other=/dev/hda2
#   label=dos

At 07:47 PM 1/1/00 +0100, Petr Cech wrote:
>On Fri, Dec 31, 1999 at 07:30:40PM -0800 , Ross Boylan wrote:
>> [This is only a cc; I got the address wrong first try--Ross]
>> Package: lilo
>> Version: 21 (unstable--from boot-floppy 2.2.3)
>> severity: grave
>> After lightly editing /etc/lilo.conf (I set boot=/dev/hda6 and put video to
>> extended) I ran lilo.
>> It failed with the error message
>> 	Not a Number "compact"
>where did you put it? I have
>and it works.
>> I tried editing the lilo.conf to say COMPACT, but it didn't help.  (It does
>> say compact).
>				Petr Cech
>Debian GNU/Linux maintainer - www.debian.{org,cz}
>           cech@atrey.karlin.mff.cuni.cz

Reply to: