[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Booting on an Intel SC450NX 4-way (4x Xeon)

I´m trying to install Debian on an Intel SC450NX 4-way server, wich is 
a 4x Xeon System with 1GB ram, 2x scsi onboard, 2x 100MBit/s, ATAPI
cdrom, floppy.

The Server is provided by Lin4Net (http://www.lin4net.de/) and Intel
for testing for a short time. Thanks to them.


When I boot with the slink CD´s I just get "boot failed". So back to
the disks, now it boots a bit.

ncr53c896-1:15: ERROR (0:4) (8-0-0) (0/7) @ (scripth 5e0:878b0000)
ncr53c896-1: script cmd = 80080000
ncr53c896-1: regdump: ca 00 80 07 47 00 06 03 06 08 00 00 80 00 0f 02.
ncr53c896-1: have to clear fifos.
ncr53c896-1: unexpected disconnect
ncr53c896-1: restart (scsi reset).
scsi: detected 2 SCSI disks total.
assertion "target == (cmd->target &0xf)" failed: file "ncr53c8xx.c", line 6379


Now I tried the disks from potato and they worked. I installed the
resc1440.bin and the three drivers disks without problem, then I
installed base from nfs. I had a problem with lilo, becaue the kernel
was behind cylinder 1024, but that was expected. So instead of lilo I
used a bootdisk to get the system started.

Ater booting the keyboard was back to US layout and not the selected
german layout so theres some bug in the keymap handling.

dselects apt method suggested to use stable, but potato should be
used. Its not a bug, because stable should be potato when the script
comes out, but for now its a bit anoying that one has to change the

A bit later dselect/select came up with a slight problem with perl
(bringing up the sugestion screen) but suggested a working
correction. Just a unwanted extra screen.

Then the installation began:

First round:
pcmcia-cs failed during removing with: "no pcmcia driver in /proc/devices"
"/sbin/cardctrl eject" in the prerm script is the bad one here.

lilo failed for the obvious 1024 cylinder reason I got myself into.
Moving /boot around fixed that, but it was my fault anyway.

Second round:
debconf didn´t work (unitialized variables) during unpacking and all

Running dpkg-reconfigure debconf and saying not to preconfigure
packages and to use the textmode configuration helped.

Third run:

Whats this LDAP stuff?

gettext failed to install (xemacs-common is not yet installed/configured)

Fourth run:

gettext works now


apt-get install smail

exim get removed and smail installed, but no configuration (I skipped
exims configuration).


apt-get install kernel-source-2.2.13
cd /usr/src
tar -xIvvf kernel-source-2.2.13.tar.bz2  [ bunzip2 is missing ]

Shouldn´t bzip2 be essential?


Kernel compilation:

# time make -j5 dep clean bzlilo modules modules_install

real	1m18.975s
user	4m7.840s
sys	1m6.520s

With vga framebuffer (just too see the 4 penguins at boottime :) so
some of the system time is probably for the vga16 framebuffer.

All together a managable installation. Just the usual "unstable" extra 

Great work alltogether.


Reply to: