[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem building debian meta-package under Ubuntu-MATE 18.04 LTS

Hi Ross

On Sat, Mar 09, 2019 at 04:34:21PM +0100, Ross Gammon wrote:
> >>> Traceback (most recent call last):
> >>>   File "/usr/share/blends-dev/blend-gen-control", line 93, in <module>
> >>>     blend += aptcache(args.release, [args.dir, '/etc/blends'])
> >>>   File "/usr/lib/python3/dist-packages/blends.py", line 722, in aptcache
> >>>     cache.update()
> >>>   File "/usr/lib/python3/dist-packages/apt/cache.py", line 546, in update
> >>>     raise FetchFailedException(e)
> >>> apt.cache.FetchFailedException: W:GPG error: http://ftp.debian.org/debian unstable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 7638D0442B90D010 NO_PUBKEY 04EE7237B7D453EC, E:The repository 'http://ftp.debian.org/debian unstable InRelease' is not signed.
> >>> /usr/share/blends-dev/Makefile:63: recipe for target 'bio-linux-tasks.desc' failed
> >>> make[2]: *** [bio-linux-tasks.desc] Error 1
> > In other words:  Tony did
> >
> >    gbp clone https://salsa.debian.org/blends-team/bio-linux
> >    cd bio-linux
> >    make dist
> >
> > but under *Ubuntu* and this machine seems to behave different than a
> > Debian machine requesting a key to parse the packages file.  I can not
> > reproduce it under Debian and I'm hoping for some input of people who
> > know Ubuntu better than me.
> Hmm. This was working for me only a month or so ago on Ubuntu Bionic. We
> use one of the Debian Multimedia metapackages in Ubuntu Studio. Every
> release I normally merge the latest blends package from Debian, and then
> backport it to my ppa.
> But I am getting the same error with both your bio-linux and the
> multimedia blend now.
> It looks like something might have changed in the Ubuntu apt package?
> There was an update in the last few days in Ubuntu. But I can't help
> much further without knowing much about how blends or apt work.

Thanks for confirming.  Its nice to know that it used to worked but
stopped working after some change in apt.  My (totally uneducated) guess
is that apt became more picky about some signatures and we either need
to find out how to provide these or seek for an option to revert to the
"classig" behaviour which should be good enough for read only access to
the packages file.

Does the changelog of your locally installed apt uncover some hint?
Some change inside the manpage which could provide a clue?

Kind regards



Reply to: