[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Simple-CDD unable to find package

> -----Original Message-----
> From: Michael Yust [mailto:mikey@nmgi.com]
> Sent: Monday, December 29, 2008 3:56 PM
> To: 'debian-custom@lists.debian.org'
> Subject: Simple-CDD unable to find package
> Greetings.
> I am trying to create a custom CD off a lenny test system. I'm using
> the following command to build it.
> build-simple-cdd --profiles york --local-packages /home/mikey/lenny
> When I run this, it errs at the end with...
> Finished: 353 packages placed
> purging /home/mikey/my-simple-cdd/tmp//extras
> including description: /home/mikey/my-simple-
> cdd/profiles/york.description
> simple-cdd: extra files for simple-cdd
> ERROR: missing required packages from profile york:  dc-system
> I ran a locate for dc-system and it returned these paths...
> mikey@debian:~/my-simple-cdd$ locate dc-system
> /home/mikey/lenny/nymgy/dc/dc-system_5.0.1~svn7045_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6520_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6527_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6530_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6644_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6646_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6655_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6663_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6690_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6881_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6903_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6916_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6923_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn6967_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn7017_all.deb
> /home/mikey/lenny/nymgy/dc-old/dc-system_5.0.1~svn7019_all.deb
> /home/mikey/my-simple-cdd/tmp/mirror/pool/main/d/doublecheck/dc-
> system_5.0.1~svn7045_all.deb
> I talked with my co-workers and they tell me the package name is
> correct. I am unable to determine why it's not including the package
> when it exists in the tmp/mirror directory as well as the local package
> directory I specify.
> Can anyone help point me in the right direction to resolve this?
> Thanks,
> Mike Yust
> --
> To UNSUBSCRIBE, email to debian-custom-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
> listmaster@lists.debian.org

I may have uncovered my own answer, which raises another question.

I looked at the debian-cd script, and I discovered that it's actually asking for the package in ./tmp/cd-build/lenny/CD1/pool/main/d/...
When I examined that directory, I found my package (dc-system) was missing from that location and therefore was causing the build to err.

This brings a few other questions to my mind now. 

1) What is the best way to include that package to that location? Can it be simply copied to that directory?
2) What is the likely reason it was not included in the first place even though I specified the local package directory? I'm confused as to how the script decided not to include it.

Thanks in advance.

-Mike Yust

Reply to: