[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: openmosix and process migration

-----old problem solved------
I know it's been a while... I figured this one out on my own almost right away after sending the email (go figure)...
turns out
$cat /proc/[xsiPID]/cantmove

which means shared memory.  openmosix just can't deal with that.

-------new problem---------
anyways, along the same topic -
I have another process mprime  (aka prime95 for windoze)
$cat /proc/[mprimePID]/cantmove
gives nothing.
It is constantly migrating back and forth between a better node and the node the process was started on.  (it's current
count is at 18488 migrations)

obviously this is stupid.  Migrating a process that many times is no good for cluster performance.  For whatever reason,
it cannot stay on a foreign node, but openmosix can't seem to detect this and keep it on the node the process was
started on.
Is there a way to prevent this process from migrating out?  I know it's kind of stupid to be running this on a cluster
when I don't want it to migrate.

for the record, I have tried
$echo 1 > /proc/[PID]/lock
but then I
$cat /proc/[PID]/lock
??  why can't I write a 1 to lock the pid?

I have googled and googled and have not found any other ways to prevent a process from migrating...
thanks in advance!

----- Original Message -----
From: "Doug" <SupportList@dougtheslug.ca>
To: <debian-beowulf@lists.debian.org>
Sent: Sunday, February 27, 2005 11:29 PM
Subject: openmosix and XSI

> hey, I was wondering if anyone could clue me in as to why this program isn't migrating.  (yes, other apps do migrate,
> it's pretty easy to get other things to migrate)
> I know there are a variety of reasons that a process won't migrate, but this one seems as if it should, yet it
> Anyways, I'm trying to run XSI Softimage on my cluster.  [Yes, I know XSI has special server-client stuff for
> distributed rendering, but I use the cluster for a variety of things, and I just want XSI to run on there also]
> but it just won't migrate to a free node.  It doesn't appear to be doing a large amount of I/O.  In fact, the hard
> light never blinks.  And as far as I can tell, it isn't a daemon, or spawned from a daemon (which supposedly prevents
> processes from migrating)
> my current cluster setup with relevant nodes -
> 1) 'gateway node' - p4 1.5 ghz, 768M ram (2 gigs swap, completely untouched) - this is the machine with X installed
> where I run all my apps from.  I want apps to migrate off to other dummy nodes once they're started.
> 2) another node - amd sempron 2400+, 512M ram - this is the machine I expect the process to migrate to, because it
> have the highest processor rating out of all the machines currently in the cluster.
> now, XSI, when rendering, appears to run a few processes, each which uses about 180M of ram.  Could it be that it
> there's not enough ram in the other machines to warrant a migration?  is that just too big to transfer?  (100mbps
> network topology)
> thoughts?  why won't it migrate?
> maybe if someone has a better/proper list of reasons why a process might not migrate, I could figure out what's
> preventing it from moving?  (the main two things I've heard of is lots of hard drive I/O will prevent a process from
> migrating or bring it back, as well as daemons supposedly won't migrate, or processes spawned from a daemon)
> -doug

Reply to: