[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with mpich


I've just installed frozen on my laptop (Thinkpad 570, PII 366, 64MB,
custom 2.2.14 kernel), and I'm having trouble getting mpi to work.  I
want to develop a parallel program on my machine, and then do
production runs on something more serious.  In any case, I installed
mpich and then changed the /etc/mpich/machines.LINUX file to read (instead of localhost, so that I don't need a nameserver to
run mpi).  I then made a .rhosts file that read boo

(my username on the laptop is boo).  To test it, I ran 

rsh ls

and it worked fine.  Then I tried to compile the tests
in /usr/doc/mpich/examples/code.  I ran mpireconfig on the makefile
and then make cpi.  Everything seemed to make fine, but when I ran cpi
(mpirun -np 1 cpi), it just sat there at 97% of cpu usage, stuck at
MPI_Init().  Is there something that I'm missing?  I'd appreciate any

Walter Landry

p.s. I couldn't use lam.  The parallel library I use doesn't seem to
want to compile with lam.  It has no problem compiling with mpich.

Reply to: