[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: bullseye-backports: collectd's netlink plugin does not work anymore


I tested this now on a second system, and there the behaviour is the same. With the version from backports, netlink does not work.

However, I compiled it from debian sources there and it works!
Thus, it looks like that something is wrong with the binary on the mirror?!
Is the version on the mirrors maybe build against other library versions? I tried to look up the build log file, but cannot find it for amd64... Why isn't there one here: https://buildd.debian.org/status/package.php?p=collectd&suite=bullseye-backports ?


On 17.03.2023 09:27, reox wrote:

Yesterday I installed collectd from bullseye-backports because I wanted the NUT plugin back. While NUT works fine now, it seems that the netlink plugin is broken instead. When I start collectd I get these error messages:

    netlink plugin: link_filter_cb: IFLA_STATS64 attribute has insufficient data.
     netlink plugin: ir_read: mnl_socket_recvfrom failed: Success
    read-function of plugin `netlink' failed. Will suspend it for 20.000 seconds.
     netlink plugin: ir_read: mnl_socket_recvfrom failed: Protocol error
    read-function of plugin `netlink' failed. Will suspend it for 40.000 seconds.

My configuration is pretty much standard:
<Plugin netlink>
         Interface "br0"
         Interface "ppp0"
         Interface "wg0"
         VerboseInterface "br0"
         VerboseInterface "ppp0"
         VerboseInterface "wg0"
         IgnoreSelected false

and has worked before. I also tried with Interface "All" but it seems the interfaces I use there do not matter.
I also tried with a reboot in between, but that had no effect either.

I tried to understand whats happening there, but the struct that is used here (rtnl_link_stats64 from linux/if_link.h) should not have been changed and should have the same size. Furthermore, collectd has the same codebase (5.12.0), thus there should be no such problems? As far as I understood it, the define HAVE_RTNL_LINK_STATS64 should be defined in bullseye too and thus the same code was working before. Do I maybe miss some other dependency from backports? But there is for example no libmnl0 in backports...
I installed collectd in the following way:

Commandline: apt install collectd/bullseye-backports
Install: libldap-2.5-0:amd64 (2.5.13+dfsg-2~bpo11+1, automatic)
Upgrade: collectd:amd64 (5.12.0-7, 5.12.0-11~bpo11+1), collectd-core:amd64 (5.12.0-7, 5.12.0-11~bpo11+1)

Maybe someone has a hint for me what I could do?


Reply to: