[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Package install failure - dpkg: error processing package xrdp (--configure)


I think I incorrectly reported this as Followup-For: Bug #862837, so here it is to the backports mailing list.

Upon upgrading xrdp from xrdp/0.9.1-4 to xrdp/0.9.1-9 (jessie backports), xrdp
still doesn't start. I get these errors in the journal:

Failed at step RUNTIME_DIRECTORY spawning /bin/sh: File exists
xrdp.service: control process exited, code=exited status=233

I believe there are two issues that prevent the start:

1. /var/run/xrdp needs to be chgrp'd to xrdp, otherwise xrdp will never be able
to start (that bug is actually present for a long time, I've always worked
around it using a Puppet rule)
2. I needed to apply the workaround mentioned in https://bugs.debian.org/cgi-
bin/bugreport.cgi?bug=854548;msg=30 to finally make it start up

I hope this is helpful.


-- System Information:
Debian Release: 8.9
  APT prefers oldstable-updates
  APT policy: (500, 'oldstable-updates'), (500, 'oldstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.4.83-1-pve (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages xrdp depends on:
ii  adduser              3.113+nmu3
ii  init-system-helpers  1.22
ii  libc6                2.19-18+deb8u10
ii  libfuse2             2.9.3-15+deb8u2
ii  libjpeg62-turbo      1:1.3.1-12
ii  libopus0             1.1-2
ii  libpam0g             1.1.8-3.1+deb8u2+b1
ii  libssl1.0.0          1.0.1t-1+deb8u6
ii  libx11-6             2:1.6.2-3
ii  libxfixes3           1:5.0.1-2+b2
ii  libxrandr2           2:1.4.2-1+b1
ii  lsb-base             4.1+Debian13+nmu1
ii  ssl-cert             1.0.35

Versions of packages xrdp recommends:
pn  fuse      <none>
ii  xorgxrdp  0.9.1-9~bpo8+1

Versions of packages xrdp suggests:
pn  guacamole  <none>

Versions of packages xorgxrdp depends on:
ii  libc6                                  2.19-18+deb8u10
pn  xorg-input-abi-21                      <none>
ii  xserver-xorg-core [xorg-video-abi-18]  2:1.16.4-1+deb8u2

Versions of packages xorgxrdp recommends:
ii  xorg  1:7.7+7

Versions of packages xrdp is related to:
pn  vnc-server           <none>
pn  xserver-xorg-legacy  <none>

-- Configuration Files:
/etc/pam.d/xrdp-sesman changed [not included]

-- debconf-show failed

Reply to: