[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Handbrake in w-b uninstallable

Problems with HandBrake in w-b persist!

# export LANG=C; apt-get install -t wheezy-backports handbrake
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 handbrake : Depends: libgstreamer-plugins-base1.0-0 (>= 1.0.0) but it is not going to be installed
             Recommends: gstreamer1.0-libav but it is not going to be installed
             Recommends: gstreamer1.0-pulseaudio but it is not going to be installed or
                         gstreamer1.0-alsa but it is not going to be installed
             Recommends: gstreamer1.0-x but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Also, if I try installing gstreamer1.0, I get lots of dependency errors.

Best wishes,

2014-05-29 16:45 GMT+02:00 Mads Hansen <d@taba.se>:
Hi Vincent,

Thanks for your comments. According to the documentation (https://trac.handbrake.fr/wiki/Preferences#advanced), Handbrake actually uses libdvdnav by default instead of libdvdread:
There are two different open source libraries for reading data from a DVD. The older one, libdvdread, is what HandBrake traditionally used. It does not even attempt to "play" a DVD the way a DVD playing machine would. Libdvdnav does try to navigate disc structure like an actual player. This is more sophisticated, and often works better. As such, it is now HandBrake's default DVD reading engine. To disable it and return to the days of libdvdread, uncheck this box.
So, since libdvdread isn't even enabled by default, most users probably wouldn't even notice the change. I can't see how a version bump would break anything.

Best regards,

On 05/29/2014 04:05 AM, Vincent Cheng wrote:
On Wed, May 28, 2014 at 8:38 AM, Mads Hansen <d@taba.se> wrote:
How about I make a new revision of the Handbrake package that recommends
libdvdread >= 4.2.1? I'm guessing an absolute dependency would be considered
bad practice when it's not strictly necessary?
Would adding a Recommends field be an appropriate solution?
If you don't know or are unable to figure out why a dependency (either
build or runtime, doesn't matter) was added to a particular package, I
suggest contacting the maintainer first to find out why, before you
make changes that could potentially break that package.


To UNSUBSCRIBE, email to debian-backports-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: https://lists.debian.org/53874819.1020301@taba.se

Prof. Domenico Cufalo
Via Contessa Matilde 14
56123 Pisa (PI)
Tel.: +393475207746
E-Mail - WebSite

Reply to: