[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PostgreSQL 9.1.1 PHP module backport

On Mon, Oct 24, 2011 at 07:24:18PM -0400, Brandon Phelps wrote:
> On 10/24/2011 4:05 AM, Gerfried Fuchs wrote:
> >* Brandon Phelps<brandon@collisionpoint.net>  [2011-10-24 05:58:30 CEST]:
> >>I have just installed the PostgreSQL 9.1.1 backport and everything
> >>is working great with the database itself.  I also upgraded libpq to
> >>9.1.1 (from 8.4, which was the squeeze default) however<?php
> >>phpinfo(); ?>  still reports that the pgsql module is still using
> >>libpq 8.4.  Is there any way I can get this up to 9.1.1 as well?  I
> >>checked for a php5-pgsql package in the backports repo but found
> >>nothing.
> >  There is no need to get the client side in php-pgsql to 9.1.1, why
> >would you think this would be a gain to you? What do you expect this
> >help you with? Do you get any warning/error messages spit out by php, or
> >is this just some feeling that you want it but don't know why?
> I was mainly just curious as to why it was still at  8.4.8 after I
> upgraded libpq to the latest version.

Have you restarted whatever runs PHP?  (Apache for mod_php, your fcgi master
if that's your kink, etc)  If you haven't, then it'll still be linked in
memory to the older libpq and hence will still be using it (an lsof -n |grep
deleted will show it, too).

> Was the php5-pgsql module compiled with a static libpq?

You'd really, really hope not.

> I also read somewhere that it is best
> to have your libpq at the same version or higher than your database.
> Perhaps this is not true?

"Best", probably.  "Worth the hassle", if it means backporting yet another
package, probably not.

- Matt

Reply to: