[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Trying to backport valgrind to lenny

Hi all,

After many successes with Russ's backport script (thanks a bunch for it), I'm 
running into problems with valgrind:

../../backport -l3.3.1 -c base.lenny.amd64 valgrind_3.5.0-3.dsc         
gpgv: keyblock resource `/root/scarsten/.gnupg/trustedkeys.gpg': general error
gpgv: Signature made Tue Nov 17 17:03:13 2009 CET using DSA key ID B29396EB
gpgv: Can't check signature: public key not found
dpkg-source: warning: failed to verify signature on ./valgrind_3.5.0-3.dsc
dpkg-source: info: extracting valgrind in valgrind-3.5.0
dpkg-source: info: unpacking valgrind_3.5.0.orig.tar.gz
dpkg-source: info: applying valgrind_3.5.0-3.diff.gz
parsechangelog/debian: warning: 'since' option specifies non-existing version
parsechangelog/debian: warning: use newest entry that is smaller than the one 
dch warning: new version (1:3.5.0-3~bpo50+1) is less than
the current version number (1:3.5.0-3).
Running pdebuild --buildresult .. --pbuilder cowbuilder --debbuildopts -d -
v3.3.1 -- --basepath /var/cache/pbuilder/base.lenny.amd64.cow
W: /root/scarsten/.pbuilderrc does not exist
  -> using cowbuilder as pbuilder
dpkg-checkbuilddeps: Unmet build dependencies: autotools-dev dpatch (>> 2.0.0) 
gdb libc6-dev-i386 (>> 2.3.0)
W: Unmet build-dependency in source
dpkg-buildpackage: warning: using a gain-root-command while being root
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value: 
dpkg-buildpackage: set LDFLAGS to default value: 
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: source package valgrind
dpkg-buildpackage: source version 1:3.5.0-3~bpo50+1
dpkg-buildpackage: source changed by root <root@kvm.atlas.local>
 fakeroot debian/rules clean
debian/rules:3: /usr/share/dpatch/dpatch.make: No such file or directory
make: *** No rule to make target `/usr/share/dpatch/dpatch.make'.  Stop.
dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2
pdebuild failed
zsh: exit 2     ../../backport -l3.3.1 -c base.lenny.amd64 

However, the build dependencies are all available:

From within the cowbuilder environment:

# apt-cache show autotools-dev dpatch gdb libc6-dev-i386| \
grep -E '^(Package|Version)'
Package: autotools-dev
Version: 20080123.1
Package: dpatch
Version: 2.0.30
Package: gdb
Version: 6.8-3
Package: libc6-dev-i386
Version: 2.7-18lenny2
Package: libc6-dev-i386
Version: 2.7-18lenny1

Any idea, what problem I'm not seeing?



Reply to: