[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lenny-backports update of dovecot-common to 1:1.2.11-1~bpo50+1 introduces dependency on libmysqlclient16


* Guido Berhoerster <guido+backports.org@berhoerster.name> [2010-03-11 14:03:53 CET]:
> the recent security update of dovecot-common to
> 1:1.2.11-1~bpo50+1 depends on libmysqlclient16 whereas
> 1:1.2.9-1~bpo50+1 depended on libmysqlclient15off.
> libmysqlclient16 in turn depends on mysql-common
> (>= 5.1.43-1~bpo50+1), so in effect this means that in order to
> install this security update people are forced to upgrade
> MySQL from stable to the lenny-backports branch.
> Please change the dependency back to libmysqlclient15off or
> backport the security fix only.
> Thanks in advance.

 It looks like the former backport did use the old libmysql15-dev
Build-Depends and the new one switched to the libmysql-dev one. This
might be related to the bugreports sent out by the mysql maintainers to
drop libmysql15-dev (alternative) build-depends (though it isn't
documented in the changelog ...).

 Marco, can you fix that please? Thanks in advance!

Reply to: