[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Duplicity 0.5.06-2~bpo40+1 doesn't work with ncftp


since duplicity was updated to 0.5.06 in the backports repo I haven't
been able to get it work with ncftp - I get the following Traceback:
Running duplicity - FAILED (code 30)
Output: Traceback (most recent call last):
  File "/usr/bin/duplicity", line 583, in ?
  File "/usr/bin/duplicity", line 577, in with_tempdir
  File "/usr/bin/duplicity", line 504, in main
    action = commandline.ProcessCommandLine(sys.argv[1:])
  File "/usr/lib/python2.4/site-packages/duplicity/commandline.py", line
519, in ProcessCommandLine
    globals.backend = backend.get_backend(args[0])
  File "/usr/lib/python2.4/site-packages/duplicity/backend.py", line 93,
in get_backend
    return _backends[pu.scheme](pu)
line 58, in __init__
AttributeError: class ErrorCode has no attribute 'ftp_ncftp_v320'

This traceback seems to be a duplicity bug, so I will report it at the
duplicity mailing list, but reading the source expose the real problem:

50         if version < "3.1.9":
 51             log.FatalError("NcFTP too old:  Duplicity requires NcFTP
version 3.1.9,"
 52                            "3.2.1 or later.  Version 3.2.0 will not
work properly.",
 53                            log.ErrorCode.ftp_ncftp_too_old)
 54         elif version == "3.2.0":
 55             log.FatalError("NcFTP (ncftpput) version 3.2.0 is not
usable by duplicity.\n"
 56                            "see:
 57                            "Please upgrade to 3.2.1 or later",
 58                            log.ErrorCode.ftp_ncftp_v320)

And finally:
apt-cache show ncftp | grep Version
Version: 2:3.2.0-1

The older 0.4.11 backport version of duplicity worked like a charm.. how
can I get it back? Is it possible to readd it to the repo?

Kind Regards


Reply to: