[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Accepted libdaemons-ruby 1.0.9-1~bpo40+1 (source all i386)

* Vincent Danjean <Vincent.Danjean@ens-lyon.org> [2008-01-08 17:37:08 CET]:
> What happens if the version given to dpkg-buildpackage does not exist in the Changelog ?

 It takes the whole changelog IIRC. Besides, this is nothing a quick try
couldn't tell you... Even if it takes only changelogs newer than that
version you would still include something doubled if you use the bpo
version because it's smaller than the version for which you did the
backport. You are thus expected to use the version that you based your
former bpo upload on.

> Version 0.8-1 in testing (changelog has 0.6-1, 0.7-1 and 0.8-1)
> Version 0.8-1~bpo40+1 in backport
>   => changelog has 0.6-1, 0.7-1, 0.8-1 and 0.8-1~bpo40+1
>      but not 0.7-1~bpo40+1 because I do not use this 'branch' at all to make
>      my backport. I start again with the latest package from testing. If needed
>      I read the 0.7-1~bpo40+1 changelog to know which change I need to make
>      but I remake (and recheck) these changes.
>   So, I think I need to include 0.8-1 and 0.8-1~bpo40+1 changes when uploading
>   Am I right ?

 Yes, exactly.

>   And does dpkg-buildpackage will do the right thing with -v0.7-1~bpo40+1 (I do not
>   think so but I do not tried yet) ? I think the correct parameter will be -v0.7-1

 Well, just try. But -v0.7-1 is the right thing to do here because 0.7-1
was the last version you based your last upload to bpo on.

 HTH, give it a try, find out quickly. :)

Reply to: