[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

OpenOffice.org dependencies


I'm trying to install OOo(2) on a Sarge from backports.  I'm not certain
whether I have all the prerequisites I need wrt the java runtime
environment, but I believe I'm currently failing even before I get to
that point.  Please bear with me as I'm still kind of new to this.

My /etc/apt/sources.list contains:
deb http://www.backports.org/debian/ sarge-backports main
deb-src http://www.backports.org/debian/ sarge-backports main

I've set my /etc/apt/preferences to:
Package: *
Pin: release a=sarge-backports
Pin-Priority: 50

I'm trying to install via:
aptitude -t sarge-backports install openoffice.org

and I get:
E: Unable to correct problems, you have held broken packages.
E: Unable to correct dependencies, some packages cannot be installed
E: Unable to resolve some dependencies!
The following packages have unmet dependencies:
  openoffice.org: Depends: openoffice.org-base (> 2.0.1) but it is not

And if I do:
aptitude -t sarge-backports show openoffice.org-base

I get:
Package: openoffice.org-base
New: yes
State: not installed
Version: 2.0.1-4bpo1
Priority: optional
Section: editors

So I wonder whether 2.0.1-4bpo1 is actually supposed to be evaluated as
(> 2.0.1).  Maybe the dependency should read (>= 2.0.1) or a newer
package is in the works?


PS: I tried subscribing to this list, and I've got a confirmation
request which I replied to yet I haven't received a confirmation that I
was actually added to the list.  Also clicking the link in the
confirmation request results in a page saying:

Bad confirmation string
Invalid confirmation string: ...

So please cc: me for the time being until I get that sorted out.

Reply to: