[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#344929: Missing version on asciidoc build-dep



On Thu, Dec 29, 2005 at 07:55:19PM +0100, Norbert Tretkowski wrote:
> * Gerrit Pape wrote:
> > Norbert Tretkowski wrote:
> > > Package fails to build with asciidoc 6.0.3-1 (the one in sarge) with
> > > the following message:
> > > 
> > > asciidoc -b docbook -d manpage -f asciidoc.conf git.txt
> > > DEPRECATED: git.txt: line 582: title arguments: use attribute lists
> > > xmlto man git.xml
> > > xmlto: input does not validate (status 3)
> > > 
> > > Updating asciidoc to 7.0.2-4 fixes the issue.
> > 
> > Hi Norbert, yes, ok. But why's that a bug? The git and cogito
> > packages are for sid and etch, and both have at least version
> > 7.0.2-4 of the asciidoc package.
> 
> Correct... I stumpled across this problem while I created git and
> cogito packages for sarge (which are both available on backports.org
> now).

That's good news, it has been asked for on the git development list,
thanks.

> > A versioned dependency can cause inconvenience, so I only want to
> > specify a version if really necessary.
> 
> What problems could a build-dep on asciidoc (>= 7.0) cause?

Not specifically asciidoc, but versioned dependencies in general.  I
still have an issue with the bcron-run package, a cron replacement that
Provides:, Replaces:, Conflicts: cron, to be installed as an alternative
to the standard cron package.  anacron can't be installed with bcron-run
due to the versioned dependency, and because there's no versioned
Provides:.

Regards, Gerrit.


Reply to: