[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted collectd 5.1.0-3~bpo60+1 (source all amd64)



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 03 Aug 2012 12:04:12 +0000
Source: collectd
Binary: collectd-core collectd collectd-utils collectd-dbg collectd-dev libcollectdclient-dev libcollectdclient0
Architecture: source amd64 all
Version: 5.1.0-3~bpo60+1
Distribution: squeeze-backports
Urgency: high
Maintainer: Sebastian Harl <tokkee@debian.org>
Changed-By: Sebastian Harl <tokkee@debian.org>
Description: 
 collectd   - statistics collection and monitoring daemon
 collectd-core - statistics collection and monitoring daemon (core system)
 collectd-dbg - statistics collection and monitoring daemon (debugging symbols)
 collectd-dev - statistics collection and monitoring daemon (development files)
 collectd-utils - statistics collection and monitoring daemon (utilities)
 libcollectdclient-dev - client library for collectd's control interface (development file
 libcollectdclient0 - client library for collectd's control interface
Closes: 585975 592623 592880 592909 595756 596128 605092 612784 614439 615840 619123 625323 630968 631167 632940 634690 636818 639796 653879 656271 656274 660918 662040 662174 664429 672739 673693 673697 673769 673888 673890 674044 674065 674459 674589 674629 676383 677842 677902 677908 677949 678016 678048 678157 678467 678614 679281 679355 679544 681216 681363
Changes: 
 collectd (5.1.0-3~bpo60+1) squeeze-backports; urgency=low
 .
   * Rebuild for squeeze-backports.
   * debian/rules, debian/control:
     - Disabled modbus plugin, libmodbus-dev is not available on Squeeze.
     - Disabled AMQP plugin, librabbitmq-dev is not available on Squeeze.
   * debian/rules, debian/collectd-core.overrides:
     - Changed JAVA_HOME to /usr/lib/jvm/java-6-openjdk (without arch).
   * debian/collectd.conf:
     - Removed sample config for the 'amqp' plugin.
 .
 collectd (5.1.0-3) unstable; urgency=low
 .
   * debian/patches/migrate-4-5-df.dpatch, debian/collectd-core.postinst:
     - Added patch to fix the migration of 'df' values in migrate-4-5.px;
       thanks to 'markuskaindl' for reporting this on IRC.
     - Pass --rrdfilter and --rrdtool parameters to migrate-4-5.px in order to
       let the script find those binaries/scripts.
     (Closes: #681363)
   * debian/collectd-core.collectd.init.d:
     - Catch disabled state in start and restart and don't exit with an error
       status. Amongst others, this fixes an upgrade of collectd when the
       daemon is disabled. Thanks to Florian Ernst for reporting this and
       Evgeni Golov for providing (an early) patch (Closes: #681216).
     - Don't use 'set -e' and 'exit 0' (at the end) in order to let return
       statuses propagate correctly. (cf. #681216)
 .
 collectd (5.1.0-2) unstable; urgency=low
 .
   * debian/collectd-core.postinst:
     - Don't create unused temp. directory.
   * debian/control, debian/rules:
     - Build depend on libmodbus-dev and enabled modbus plugin. 5.1 now
       supports libmodbus 3; thanks to Ivo De Decker for reporting this
       (Closes: #639796).
   * debian/po:
     - Updated Swedish debconf translation; thanks to Martin Bagge
       (Closes: #677842).
     - Added Slovak debconf translation; thanks to 'helix84'
       (Closes: #677902).
     - Updated Danish debconf translation; thanks to Joe Dalton
       (Closes: #677908).
     - Updated Czech debconf translation; thanks to Martin Šín
       (Closes: #677949).
     - Updated Russian debconf translation; thanks to Yuri Kozlov
       (Closes: #678016).
     - Updated Portuguese debconf translation; thanks to Américo Monteiro
       (Closes: #678048).
     - Updated Polish debconf translation; thanks to Michał Kułach
       (Closes: #678157).
     - Updated Galician debconf translation; thanks to Jorge Barreiro
       (Closes: #678467).
     - Updated French debconf translation; thanks to Steve Petruzzello
       (Closes: #678614).
     - Updated Spanish debconf translation; thanks to Omar Campagne
       (Closes: #679281).
   * debian/collectd-core.collectd.init.d:
     - Source /lib/lsb/init-functions in order to make systemd work in
       compatibility mode; thanks to Michael Stapelberg for reporting this
       (Closes: #679544).
     - Use log_* and status_of_proc functions from LSB's init functions to
       make collectd's output look like all the other output; thanks to
       Matthias Urlichs for pointing this out (Closes: #679355).
 .
 collectd (5.1.0-1) unstable; urgency=low
 .
   * New upstream release (Closes: #630968):
     - syslog plugin now supports logging notifications; thanks to Trent W.
       Buck for suggesting this (Closes: #632940).
     New plugins:
     - AMQP output plugin: amqp
     - AIX logical partitions statistics: lpar (disabled in Debian; AIX only)
     - Network interface card statistics: ethstat (disabled on kfreebsd; Linux
       only)
     - Linux software-RAID device information: md (disabled on kfreebsd; Linux
       only)
     - Information about Non-Uniform Memory Access: numa (disabled on kfreebsd;
       Linux only)
     - Redis key-value database server statistics: redis (disabled in Debian;
       libcredis is not available)
     - Check thresholds and for missing values: threshold
     - Varnish HTTP accelerator daemon statistics: varnish
     - Sends data to Carbon, the storage layer of Graphite: write_graphite
     - Write values to a MongoDB NoSQL database server: write_mongodb (disabled
       in Debian; libmongoc is not available)
     - Write values to a Redis key-value database server: write_redis (disabled
       in Debian; libcredis is not available)
     New targets:
     - Upgrade data-sets from v4 clients to v5: v5upgrade
   * debian/rules:
     - Disabled lpar plugin -- this requires AIX (perfstat).
     - Disabled redis and write_redis plugins -- they require libcredis.
     - Disabled write_mongodb plugin -- this requires libmongoc.
     - Disabled ethstat, md, and numa plugins on kfreebsd -- these plugins are
       Linux specific.
     - Install contrib/exec-ksm.sh as example.
   * debian/control:
     - Added build-dep on librabbitmq-dev, required by the AMQP plugin.
     - Added build-dep on libvarnish-dev, required by the varnish plugin.
   * debian/collectd-utils.install:
     - Install collectdctl and collectdctl.1 to collectd-utils.
   * debian/libcollectdclient0.symbols:
     - Added lcc_sort_identifiers introduced in 5.1.0.
   * debian/NEWS.Debian:
     - Documented the upgrade from version 4 to 5.
   * debian/collectd-core.install:
     - Install migrate-4-5.px.
   * debian/collectd-core.{config,postinst,templates}:
     - Added debconf queries and code to automatically migrate from v4.
   * debian/source/format:
     - Set to "1.0" for now.
   * debian/po/:
     - Updated German debconf template translation.
   * debian/collectd-core.override:
     - Limit netlink override to appropriate architectures.
 .
 collectd (4.10.7-2) unstable; urgency=low
 .
   * debian/po:
     - Updated Czech debconf translation; thanks to Martin Šín
       (Closes: #673693).
     - Updated Polish debconf translation; thanks to Michał Kułach
       (Closes: #673697).
     - Updated Dutch debconf translation; thanks to Jeroen Schot
       (Closes: #673769).
     - Updated Swedish debconf translation; thanks to Martin Bagge
       (Closes: #673888).
     - Updated Russian debconf translation; thanks to Vladimir Zhbanov
       (Closes: #673890).
     - Added Italian debconf translation; thanks to Beatrice Torracca
       (Closes: #674044).
     - Updated Portuguese debconf translation; thanks to Américo Monteiro
       (Closes: #674065).
     - Updated Danish debconf translation; thanks to Joe Dalton
       (Closes: #674459).
     - Updated Brazilian Portuguese debconf translation; thanks to Adriano
       Rafael Gomes (Closes: #674589).
     - Updated French debconf translation; thanks to Steve Petruzzello and
       Christian PERRIER (Closes: #674629).
     - Updated Spanish debconf translation; thanks to Omar Campagne
       (Closes: #676383).
     - Updated German debconf translation based on Holger Wansing's feedback on
       debian-l10n-german.
 .
 collectd (4.10.7-1) unstable; urgency=low
 .
   * New upstream release.
     - Fixed an endless loop in case the datadir is a symlink pointing to a
       non-existent target; thanks to Michael Prokop for reporting this and
       Jonathan Nieder for providing the patch (Closes: #619123).
     - Use bsd/nlist.h rather than the deprecated nlist.h on FreeBSD fixing a
       FTBFS on kfreebsd; thanks to Tobias Frost for reporting this
       (Closes: #664429).
   * debian/patches/:
     - Removed ipvs_h_include.dpatch -- applied upstream.
     - Added rtnl_dump_filter.dpatch, updating the rtnl_dump_filter() signature
       to recent versions of iproute2.
   * debian/rules:
     - Use dpkg-buildflags to determine compiler/linker flags; this also
       enables hardening build flags; thanks to Moritz Muehlenhoff for
       providing the patch (Closes: #656271).
     - Don't force building of the ipvs plugin. The ip_vs.h check has been
       fixed in configure.
     - Use /usr/share/javahelper/java-arch.sh to determine the Java
       architecture directory, thus, making sure armhf and armel are supported
       as well; thanks to peter green for reporting this and providing the
       pointer (Closes: #656274).
     - Work around #673431 (kvm.h requires sys/types.h) by forcing the processes
       plugin on kfreebsd and manually defining HAVE_STRUCT_KINFO_PROC_FREEBSD.
   * debian/README.Debian:
     - Added section 'Cleanup of old data' explaining how to get rid of
       out-dated data files (e.g. RRD files).
   * debian/control:
     - Updated to standards-version 3.9.3 -- no changes.
     - Build depend on javahelper providing java-arch.sh.
     - Use linux-any, kfreebsd-any, etc. rather than hardcoded list of
       non-Linux architectures to make life of porters easier; thanks to Robert
       Millan for reporting this and providing a pointer to the fix
       (Closes: #634690).
     - Explicitly build-depend on libkvm-dev on kfreebsd; this is required by
       the processes, swap and tcpconns plugins.
   * debian/collectd-core.postrm, debian/collectd-core.templates:
     - Prompt the user (debconf priority high) when purging the collected data
       providing an option to opt out. The question defaults to remove the
       data; thanks to Trent W. Buck for reporting and discussing this
       (Closes: #631167).
   * debian/collectd-core.collectd.init.d:
     - Added cpufrequtils to should-start, else collectd does not reliably
       detect all CPUs; thanks to Mathias Bauer for reporting and debugging
       this (Closes: #662040).
     - Use the exit codes specified by LSB in 'status' command; thanks to
       Michael Prokop for reporting this (Closes: #615840).
   * debian/po/:
     - Added Danish debconf template translation; thanks to Joe Dalton
       (Closes: #660918).
     - Added Brazilian Portuguese debconf template translation; thanks to
       Adriano Rafael Gomes (Closes: #662174).
     - Added Polish debconf template translation; thanks to Michał Kułach
       (Closes: #672739).
 .
 collectd (4.10.4-1) unstable; urgency=low
 .
   * New upstream release.
     - Added support for Yajl version 2; thanks to John Stamp for reporting
       this (Closes: #653879).
     - collectd.conf(5) now documents the "Globals" config option and that this
       is required for the "perl" and "python" plugins; thanks to Jeff Green
       for reporting this (Closes: #612784).
     - Be more verbose about why loading a plugin fails; thanks to Martin
       Steigerwald for reporting this (Closes: #585975).
     - Don't abort if including a config file fails; thanks to Reinhard Tartler
       for reporting this (Closes: #592880).
     - Fixed FTBFS with GCC 4.6; thanks to Matthias Klose for reporting this
       and Peter Green and Colin Watson for providing patches
       (Closes: #625323).
     - Added support for libnotify 0.7; thanks to Michael Biebl for reporting
       this (Closes: #636818).
     - Fixed FTBFS with current libiptc; thanks to Lucas Nussbaum for reporting
       this (Closes: #614439).
   * debian/patches:
     - Removed bts595756-notify_email-segfault -- included upstream.
     - Removed bts592623-curl_json-file -- included upstream.
     - Removed bts596128-reheap-fix -- included upstream.
     - Removed CVE-2010-4336 -- included upstream.
   * debian/rules:
     - Append DEB_BUILD_ARCH to JAVA_HOME; this is how it's done in the OpenJDK
       package.
     - Split 'build' target into 'build-arch' and 'build-indep' as recommended
       by policy.
   * debian/patches/ipvs_h_include, debian/rules:
     - Let the ipvs plugin use linux/ip_vs.h rather than net/ip_vs.h. Also,
       make sure to look for the header in /usr/include rather than the kernel
       directory (which has been deprecated).
     - Force building of the ipvs plugin since configure is not currently able
       to correctly check for ip_vs.h.
   * debian/control:
     - Updated standards-version to 3.9.2 -- no changes.
   * debian/collectd-core.collectd.init.d:
     - Added a description LSB header field.
   * debian/collectd-core.overrides:
     - Updated entry for java's binary-or-shlib-defines-rpath.
 .
 collectd (4.10.1-2.1) unstable; urgency=high
 .
   * Non-maintainer upload by the security team
   * Fix DoS in RRD file creation (Closes: #605092)
     Fixes: CVE-2010-4336
     Thanks to Florian Forster
 .
 collectd (4.10.1-2) unstable; urgency=medium
 .
   * debian/rules:
     - Added support for ‘powerpcspe’ to the Java arch mapping; thanks to
       Sebastian Andrzej Siewior for the patch (Closes: #592909).
   * debian/patches:
     - Added bts595756-notify_email-segfault -- upstream patch fixing a
       segfault in the 'notify_email' plugin; thanks to Manuel CISSE for
       reporting this (Closes: #595756).
     - Added bts592623-curl_json-file -- upstream patch fixing access to
       file:// URLs in the 'curl_json' plugin; thanks Baptiste Mille-Mathias
       for reporting this and pointing out the patch (Closes: #592623).
     - Added bts596128-reheap-fix -- upstream patch fixing the 'reheap()'
       function used to manage the "read" callbacks and making sure all plugins
       get executed correctly and in each interval (Closes: #596128).
   * Set urgency to "medium" because of the RC bug-fix.
Checksums-Sha1: 
 fe02cf49511903e2e1e9e69a45eea728124e00e3 2390 collectd_5.1.0-3~bpo60+1.dsc
 55f17b17a10710641a9bf4e8c5332cef661cafcd 1630323 collectd_5.1.0.orig.tar.gz
 03fbe478f1dc17984dbeddf3103ff2d9cd739847 72855 collectd_5.1.0-3~bpo60+1.diff.gz
 a95258ac1c858c7a03c6c7c9a083feec6ad078fc 884722 collectd-core_5.1.0-3~bpo60+1_amd64.deb
 9e80ad1bf5e947f6afe1c5ff34f8df288ca9a014 77394 collectd_5.1.0-3~bpo60+1_amd64.deb
 383f04435b0b27ae42f9fb87bef7b1c6cbdcee74 88938 collectd-utils_5.1.0-3~bpo60+1_amd64.deb
 941023c5f19dd31fb21b1e1260e1403d0c6ea707 889438 collectd-dbg_5.1.0-3~bpo60+1_amd64.deb
 ba77792e648516c32301fbef8c5ab48dc9c8926d 72456 libcollectdclient-dev_5.1.0-3~bpo60+1_amd64.deb
 a948ab6c49dd6df84c7fe40b5d5b9fdc8fa82dd0 78802 libcollectdclient0_5.1.0-3~bpo60+1_amd64.deb
 8775d56193c61092c9b1e0e9e9f9604e9775240f 115476 collectd-dev_5.1.0-3~bpo60+1_all.deb
Checksums-Sha256: 
 7e4480b9b9ff1a27268fa8fedeab49c37337294cf1aa66b6e0cee5b988741376 2390 collectd_5.1.0-3~bpo60+1.dsc
 8e06c03c5467f3021565570fc86c931a43579aa6dad25ca5999d66850cd19927 1630323 collectd_5.1.0.orig.tar.gz
 2da4897c3f17092e37a48ab5f6fb284e10e4e4d7885b58fd24922170b44e9e2e 72855 collectd_5.1.0-3~bpo60+1.diff.gz
 79bd5c56af5d784f39906063488c53dafe4f121763a5a4c1908f1246ead58d09 884722 collectd-core_5.1.0-3~bpo60+1_amd64.deb
 c99cfa9e6e2b7057a2c004540a3f68106bb0329f9661f9b3f08e0f65290daa58 77394 collectd_5.1.0-3~bpo60+1_amd64.deb
 ae255e8522b481c890fc17362cba46b609e966258b258385554414b2bea90d77 88938 collectd-utils_5.1.0-3~bpo60+1_amd64.deb
 8d7eb8fd948c5ddfe2c05a6b23c9d1d61868995df7cea11ff9394eb8afaa4735 889438 collectd-dbg_5.1.0-3~bpo60+1_amd64.deb
 6c90492c05ae37433d2e04e2e8bb8babd665c764e8e18ebb50351c6b3aa2a51f 72456 libcollectdclient-dev_5.1.0-3~bpo60+1_amd64.deb
 f3a410d605a68c433aed5986c07a7880b16133be5163b85b92f15fdb37e4a0a5 78802 libcollectdclient0_5.1.0-3~bpo60+1_amd64.deb
 01b9bd8d523d9bd44761cdcf304a1ec55ad7704330e16fed25428abeb795e1a9 115476 collectd-dev_5.1.0-3~bpo60+1_all.deb
Files: 
 489149ac8872af4a11daee401c84b738 2390 utils optional collectd_5.1.0-3~bpo60+1.dsc
 adc58a0d448a359ecf737da9398898c6 1630323 utils optional collectd_5.1.0.orig.tar.gz
 ba4e113982241b11472dca7382d69584 72855 utils optional collectd_5.1.0-3~bpo60+1.diff.gz
 1e5483314d7d6d00cad9cc1f65024186 884722 utils optional collectd-core_5.1.0-3~bpo60+1_amd64.deb
 bcbb3a5f700f8dfbef41b1f6064d91a3 77394 utils optional collectd_5.1.0-3~bpo60+1_amd64.deb
 a4da113e065eff38e095e6f2ec1c9c63 88938 utils optional collectd-utils_5.1.0-3~bpo60+1_amd64.deb
 15e2bc8b3caa409a029d882f35460750 889438 debug extra collectd-dbg_5.1.0-3~bpo60+1_amd64.deb
 922c5a2efddd11aaf5f9b74f63765eac 72456 libdevel optional libcollectdclient-dev_5.1.0-3~bpo60+1_amd64.deb
 bc9d8fb31f3a494c041f2e1c0aa970c5 78802 libs optional libcollectdclient0_5.1.0-3~bpo60+1_amd64.deb
 c4a155d1ca03ee61a80eb46b7c2d7445 115476 utils optional collectd-dev_5.1.0-3~bpo60+1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAlAbxnoACgkQEFEKc4UBx/xQcACfW7eJp4jkEpwsJHeUbMQovRhQ
FKAAnisboWP+oAZVFwCcZJemKpM+Vhts
=8Byx
-----END PGP SIGNATURE-----


Accepted:
collectd-core_5.1.0-3~bpo60+1_amd64.deb
  to main/c/collectd/collectd-core_5.1.0-3~bpo60+1_amd64.deb
collectd-dbg_5.1.0-3~bpo60+1_amd64.deb
  to main/c/collectd/collectd-dbg_5.1.0-3~bpo60+1_amd64.deb
collectd-dev_5.1.0-3~bpo60+1_all.deb
  to main/c/collectd/collectd-dev_5.1.0-3~bpo60+1_all.deb
collectd-utils_5.1.0-3~bpo60+1_amd64.deb
  to main/c/collectd/collectd-utils_5.1.0-3~bpo60+1_amd64.deb
collectd_5.1.0-3~bpo60+1.diff.gz
  to main/c/collectd/collectd_5.1.0-3~bpo60+1.diff.gz
collectd_5.1.0-3~bpo60+1.dsc
  to main/c/collectd/collectd_5.1.0-3~bpo60+1.dsc
collectd_5.1.0-3~bpo60+1_amd64.deb
  to main/c/collectd/collectd_5.1.0-3~bpo60+1_amd64.deb
collectd_5.1.0.orig.tar.gz
  to main/c/collectd/collectd_5.1.0.orig.tar.gz
libcollectdclient-dev_5.1.0-3~bpo60+1_amd64.deb
  to main/c/collectd/libcollectdclient-dev_5.1.0-3~bpo60+1_amd64.deb
libcollectdclient0_5.1.0-3~bpo60+1_amd64.deb
  to main/c/collectd/libcollectdclient0_5.1.0-3~bpo60+1_amd64.deb


Reply to: