[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

rhino_1.7R2-4~bpo50+1_i386.changes is NEW

(new) rhino-doc_1.7R2-4~bpo50+1_all.deb optional doc
Documentation for rhino Java Script Engine
 Rhino is an implementation of the JavaScript language written
 entirely in Java. It is typically embedded into Java applications to
 provide scripting to end users.
 This is the documentation, including API JavaDoc, for the Rhino
 JavaScript engine.
(new) rhino_1.7R2-4~bpo50+1.diff.gz optional interpreters
(new) rhino_1.7R2-4~bpo50+1.dsc optional interpreters
(new) rhino_1.7R2-4~bpo50+1_all.deb optional interpreters
JavaScript engine written in Java
 Rhino is an implementation of the JavaScript language written
 entirely in Java. It is typically embedded into Java applications to
 provide scripting to end users.
(new) rhino_1.7R2.orig.tar.gz optional interpreters
Changes: rhino (1.7R2-4~bpo50+1) lenny-backports; urgency=low
  * Rebuild for lenny-backports.
rhino (1.7R2-4) unstable; urgency=low
  * Enable E4X support:
    - Build-Depends on libxmlbeans-java
    - Set JAR location in debian/ant.properties
    - Should fix (Closes: #567847) and (LP: #304702)
  * Bump Standards-Version to 3.8.4 (no changes needed)
  * Fix small typo in rhino-jsc manpage
  * Fix debian/copyright: don't use symlink to license
rhino (1.7R2-3) unstable; urgency=low
  * Maven POMs:
    - debian/control: add a Build-Depends on maven-repo-helper
    - debian/rules: use mh_installpoms and mh_installjar
      to install the POM and the jar to the Maven repository
    - debian/pom.xml: Debian pom.xml file as upstream doesn't provide one
    - debian/rules: new get-orig-pom to update debian/pom.xml at new upstream
  * Bump debhelper version to >= 7
  * debian/rhino.1: Describe more precisly optimization levels and add missing
    level '-1'. Thanks to Marcus Better for notifying (Closes: #558086)
  * Remove Arnaud Vandyck from Uploaders
  * Add description to debian/patches/*.diff
rhino (1.7R2-2) unstable; urgency=low
  * Switch to Quilt patch system:
    - Refresh all patches
    - Add B-D on quilt
    - Include patchsys-quilt.mk in debian/rules
  * Bump Standards-Version to 3.8.3:
    - Add a README.source to describe patch system
  * Add a manpage for rhino-debugger script
  * Build-Depends on default-jdk instead of default-jdk-builddep
    because we don't build a native GCJ package
  * Move api documentation to /usr/share/doc/rhino/api/
  * debian/control: Improve rhino-doc package long description
  * debian/copyright: Add missing BSD licence (3 clauses) for files under
  * Update my email address
rhino (1.7R2-1) unstable; urgency=low
  [ Marcus Better ]
  * Updated package descriptions.
  [ Matthias Klose ]
  * (Build-)depend on default-jre-headless/-jdk.
  * Drop alternate dependencies on java2-runtime-headless and
    java2-runtime-headless. The binary package is currently built to
    require a java5 runtime.
  [ Damien Raude-Morvan ]
  * New upstream release.
    - new 02_exclude-jdk15 patch to exclude already compiled classes
      for jdk15 rebuild: gcj doesn't handle compiling classes already
      on its classpath
    - new "rhino-debugger" launcher for Rhino Debugger Swing UI
    - update "rhino" launcher to exclude OpenJDK bundled rhino (Closes: #512498)
  * debian/{postinst,prerm }: scripts should take care of errors,
    add set -e before any instruction
  * debian/rules: add new get-orig-source target using uscan
  * debian/control:
    - Build-Depends on specialized default-jdk-builddep instead of
    - Bump Standards-Version to 3.8.1: Wrap Uploaders field
    - add Depends on ${misc:Depends}
rhino (1.7R2~pre-2) experimental; urgency=low
  * Really include the debugger. Closes: #474046.
rhino (1.7R2~pre-1) experimental; urgency=low
  * New upstream release.
  * Upload to experimental.
  * Enable build of debugger. Closes: #474046.

Override entries for your package:

Announcing to debian-backports-changes@lists.debian.org

Your package contains new components which requires manual editing of
the override file.  It is ok otherwise, so please be patient.  New
packages are usually added to the override file about once a week.

You may have gotten the distribution wrong.  You'll get warnings above
if files already exist in other distributions.
eady exist in other distributions.

Reply to: