[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted heartbeat 1:3.0.3-2~bpo50+1 (source amd64)

Hash: SHA1

Format: 1.8
Date: Thu, 08 Jul 2010 10:26:19 +0000
Source: heartbeat
Binary: heartbeat heartbeat-dev libheartbeat2 libheartbeat2-dev
Architecture: source amd64
Version: 1:3.0.3-2~bpo50+1
Distribution: lenny-backports
Urgency: high
Maintainer: Debian HA Maintainers <debian-ha-maintainers@lists.alioth.debian.org>
Changed-By: Martin Loschwitz <madkiss@debian.org>
 heartbeat  - Subsystem for High-Availability Linux
 heartbeat-dev - Subsystem for High-Availability Linux - development files
 libheartbeat2 - Subsystem for High-Availability Linux (libraries)
 libheartbeat2-dev - Subsystem for High-Availability Linux (development files)
Closes: 484868 484868 484868 485103 486071 487167 489607 503177
 heartbeat (1:3.0.3-2~bpo50+1) lenny-backports; urgency=low
   * Rebuild for lenny-backports.
   * Converted package back from 3.0 to 1.0 format
   * Include ancient entries for Lenny versions in changelog
 heartbeat (1:3.0.3-2) unstable; urgency=low
   * Add build dependency on docbook-xml.
 heartbeat (1:3.0.3-1) unstable; urgency=low
   * New upstream version 3.0.3
   * Disable strict warnings (Close: #577550)
 heartbeat (1:3.0.2+hg12555-1) unstable; urgency=low
   * New Mercurial checkout
   * Adopt patch by Florian Haas to delete libnet build dependency
 heartbeat (1:3.0.2+hg12547-2) unstable; urgency=low
   [ Martin Loschwitz ]
   * Re-add dh_installinit but delete heartbeat.init
   * Deleted some ancient files from debian-subdirectory
 heartbeat (1:3.0.2+hg12547-1) unstable; urgency=low
   [ Martin Loschwitz ]
   * Update to latest HG version
   * New copyright-file by Ante Karamatic
   * Use heartbeat standard init script instead of the old one
 heartbeat (1:3.0.2-2) UNRELEASED; urgency=low
   [ Simon Horman ]
   * Build-depend on libsensors4-dev | libsensors-dev.
   * remove ldconfig from heartbeat.{postrm,postinst}.
   [ Frederik Schüler ]
   * Add myself to uploaders.
   * Drop duplicate priority and section fields from debian/control.
   * Bump standards version to 3.8.4, no changes needed.
   * Switch to debhelper 7.
   * Switch to source version 3.0 "quilt", drop dpatch dependency.
   * Use dh_prep instead of dh_clean -k.
   * Depend on cluster-agents.
 heartbeat (1:3.0.2-1) unstable; urgency=low
   * New upstream release.
 heartbeat (1:3.0.2~rc2+hg20100127-0test1) unstable; urgency=low
   * Incorporating a whole lot of change introduced by Ante Karamatic
     from Ubuntu; thank you very much!
   * New heartbeat source checkout
 heartbeat (3.0.2~rc2-0ubuntu0ppa3) lucid; urgency=low
   * Drop hard dep on pacemaker for heartbet; moved to Recommends
 heartbeat (3.0.2~rc2-0ubuntu0ppa2) lucid; urgency=low
   * debian/heartbeat.install:
     - follow upstream changes
   * debian/control:
     - added dpatch, docbook-xsl and xsltproc to build depends
   * debian/rules:
     - (un)apply patches
   * debian/patches/01_docbook_path.dpatch:
     - use local docbook-xsl
 heartbeat (3.0.2~rc2-0ubuntu0ppa1) lucid; urgency=low
   * New upstream release
 heartbeat (3.0.beta1+hg20091102-2~bpo50+1) lenny-backports; urgency=low
   * Rebuild for lenny-backports.
 heartbeat (3.0.beta1+hg20091102-2) unstable; urgency=low
   * Added pacemaker-dependency to heartbeat as heartbeat would be
     pretty useless otherwise.
 heartbeat (3.0.beta1+hg20091102-1) unstable; urgency=low
   [ Martin Loschwitz ]
   * New upstream checkout
   * heartbeat: Provide cluster-messaging-framework
 heartbeat (3.0.beta1+hg20091012-1) unstable; urgency=low
   [ Martin Loschwitz ]
   * New upstream version
 heartbeat (3.0.beta1+hg20090915-1) unstable; urgency=low
   [ Martin Loschwitz ]
   * Removed huge parts of debian/ due to upstream package split up
 heartbeat (2.99.2+sles11r9-5) unstable; urgency=low
   [ Martin Loschwitz ]
   * fix binary-arch/binary-indep handling in debian/rules, REALLY fixing the
     duplicate file problem this time.
 heartbeat (2.99.2+sles11r9-4) unstable; urgency=low
   [ Martin Loschwitz ]
   * Fix bug introduced in -3 where some LRM regression documentation would
     be both in heartbeat and in heartbeat-common
 heartbeat (2.99.2+sles11r9-3) experimental; urgency=low
   [ Martin Loschwitz ]
   * More tweaking for the heartbeat/heartbeat-common split, based
     on the advise by Andrew Beekhof (Thank you very much!)
 heartbeat (2.99.2+sles11r9-2) experimental; urgency=low
   [ Martin Loschwitz ]
   * include send_arp as things might get troublesome otherwise
 heartbeat (2.99.2+sles11r9-1) experimental; urgency=low
   [ Martin Loschwitz ]
   * Updated to latest upstream version
 heartbeat (2.99.2+sles11r7-1) experimental; urgency=low
   [ Martin Loschwitz ]
   * Redid package structure, adding the following new packages:
     This makes the packages as compatible as possible with the according
     SLES packages; additionally, it allows to have a nearly openais-only
   * Changed Maintainer to the Debian HA-Maintainers
   * New Upstream version
 heartbeat (2.99.2-1) experimental; urgency=low
   [ Anibal Monsalve Salazar ]
   * New Upstream
   * Add myself to uploaders
   [ Simon Horman ]
   * Change distribution from sid to experimental
   * Add conflicts with pacemaker-dev (<< 1.0.1-1) to heartbeat-dev
     as older versions of pacemaker-dev need cl_malloc.h to be present
     in heartbeat-dev
   * Make sure configure and py-compile are executable if present
   * Don't run configure for clean targets.
     This causes multiple builds of the tree which takes a long time.
     Upstream commit:
     "Medium (LF 2018): Debian: build: revert changeset ddfb560ba135"
   * The correct include path for termio.h on Debian is <termio.h>
     not <sys/termio.h> - This needs to be fixed more cleanly upstream.
   * heartbeat dependancy on mawk
     With this change heartbeat now depends on both gawk and mawk.
     Clearly there is roome for improvment here. I will try and
     get things cleaned-up in upstream and unstable.
     (See: #512403)
 heartbeat (2.1.4-3) unstable; urgency=high
   * heartbeat-gui: depend on uuid-runtime rather than
     uuid-runtime | e2fsprogs as uuidgen, which is needed by hb_gui, is
     included in uuid-runtime but not e2fsprogs on Lenny. That is, a system
     (default install I think) that has e2fsprogs installed but not
     uuid-runtime would satisfy the old dependancy, but hb_gui would not
     work correctly.
     I beleive that the reason for the alternate dependancy was to allow the
     package to be built for both sarge and newer systems.  Sarge being the
     stable release. But when Lenny becomes the stable release most of the
     motivation for this will be removed.
     If this becomes a problem then a versioned dependancy could be
     intorduced. Based on the e2fsprogs ChangeLog I believe that should be
     as follows. Howerver, I have decided to take the simpler single
     dependancy option for now.
     uuid-runtime | e2fsprogs (< 1.40.4-1)
     (closes: #503177)
 heartbeat (2.1.4-2) unstable; urgency=low
   * Dependancy on uuid-runtime for heartbeat-gui
     Unfortuantely the 2.1.3-7 of this fix made it into upstream 2.1.4
     but not the 2.1.3-8 version of the fix. This should rectify this
     problem, again...
     Patch: medium_debian_uuid-duntime__e2fsprogs_dependancy_for_heartbeat-gui.patch
     Upstream-status: Pending
     (closes: #484868)
   * Dependancy on ${shlibs:Depends} for heartbeat-gui
     As per lintian error "missing-dependency-on-libc"
   * Pass --enable-libc-malloc to configure.
     --enable-glib-malloc was a typo.
     Upstream-satatus: Pending
   * Don't ignore errors in clean target of debian/rules
     As per lintian warning "debian-rules-ignores-make-clean-error"
 heartbeat (2.1.4-1) unstable; urgency=low
   * New Upstream
 heartbeat (2.1.3-8) unstable; urgency=low
   * The dependancy on uuid-runtime added in 2.1.3-7 was not a build dependacy,
     it was a regular dependancy for heartbeat. However, it should have been
     a dependancy for heartbeat-gui.
     (closes: #484868)
   * Update standards version from 3.7.3 to 3.8.0
   * Remove bashisms from character clases
     Patch: dash-case.patch
     Upsteram-Status: commit 5aea0e314a77c15437765593a7b4f3f13c829f83
                      "Low: Remove bashisms from character classes"
     Ubuntu bug #248737
 heartbeat (2.1.3-7) unstable; urgency=low
   * Remove some bashisms from ocf, xen and filesystem plugins
     Thanks to Luca Falavigna
     Patch: remove-some-bashisms-from-the-ocf-xen-and-filesystem-plugins.patch
     Upstream-Status: commit 055ffbfe69b2b3810f9c71c491c30684fd67b669
                      "Remove some Bashisms from the OCF Xen and Filesystem
     Note that upstream commit ed0972c7aa43699ae2ec31f68cac3b9cbcc5d5c5
     "removing bashisms from stonith external plugins"
     is not required as it applies to changes made after 2.1.3. At this
     point no post-2.1.3 packages have been made available in Debian.
     (closes: #487167)
   * Remove some bashisms from STONITHBasicSanityCheck and BasicSanityCheck
     Patch: remove-bashisms-from-STONITHDBasicSanityCheck.patch
     Upstream-Status: submitted to pocemaker mailing list
                      as this code has move from heartbeat to pacemaker
     Patch: use-mktemp.patch
     Upstream-Status: commit 82e3625e0198af52eb22ef8a42cebf5050ab69e3
                      "Medium: safely create tempoary files"
     (closes: #489607)
   * dopd: fix basic failover; fix hb message corruption by fprintf(stderr)
     Patch: fix-basic-failover-fix-hb-message-corruption-by-fprintf.patch
     Upstream-Status: commit 47f60bebe7b25abd88ea7b5488e66dfe187416ae
                      "dopd: fix basic failover; fix hb message corruption by
     (closes: #486071)
   * safely handle $RANDOM being empty, as the case under dash
     Patch: cope-with-empty-random.patch
     Upstream-Status: commit 597cfd99deee5128d77022c53112dfc1f8686889
                      "Low: Cope with empty $RANDOM"
   * Update series to allow using the "3.0 (quilt)" package format
     Thanks to Raphael Hertzog
     Upstream-Status: commit 70e9df3f594d73efe4336c9f74a689d6955abac8
                      "Debian: Use quilt for patching which is supported by dpkg"
     (closes: #485103)
   * Add build dependancy on uuid-runtime
     Thanks to Joshua Hutchins
     Upstream-Status: commit 597cfd99deee5128d77022c53112dfc1f8686889
                      "Medium: Debian: Build dependancy on uuid-runtime"
     (closes: #484868)
 493d6c4c291b3ab4e466eb9b3a793b74d0a11f9b 1772 heartbeat_3.0.3-2~bpo50+1.dsc
 e309b88a53432b441f408cfb9c487009a15f04c0 619496 heartbeat_3.0.3.orig.tar.gz
 b0db50556dc69d49f36dd60b4a5b186f8fef224d 26729 heartbeat_3.0.3-2~bpo50+1.diff.gz
 899e5a3cc9674a81dddbc8d50cc3a4d8087a8882 406562 heartbeat_3.0.3-2~bpo50+1_amd64.deb
 795830a6642f87115723efb9419ad1cc3abedc8b 1074288 heartbeat-dev_3.0.3-2~bpo50+1_amd64.deb
 261ca975670067064321f575fcee92e5771e541c 71958 libheartbeat2_3.0.3-2~bpo50+1_amd64.deb
 fff82c03bd772357bc72653199a50117a60d3c52 97254 libheartbeat2-dev_3.0.3-2~bpo50+1_amd64.deb
 9bb42a47187f57ea34d09a99df88dd8568fa2368a2eda415ad130acd4341618e 1772 heartbeat_3.0.3-2~bpo50+1.dsc
 413a680d2c337f3f675152c5c825b33dc1c16db1ce53415d5981c1658ced1677 619496 heartbeat_3.0.3.orig.tar.gz
 650d6c7fc004e2db29fd46e2787adb7c9ac112c0b732302741ae4d94a96c66c2 26729 heartbeat_3.0.3-2~bpo50+1.diff.gz
 7bbbe0287b461fcd4653a1bf2dc01516a37e4ae9b3e82a1d90b9aab3baf4b183 406562 heartbeat_3.0.3-2~bpo50+1_amd64.deb
 bc8c4acd5ae38a36e8eae8d55e674419ce48e8fa42334a6317d86ebd5c04b1d2 1074288 heartbeat-dev_3.0.3-2~bpo50+1_amd64.deb
 9f938ab406c1dd12c755dcdf405262dbc7e5e67fb79aec1f9be3c3e7fc53d74c 71958 libheartbeat2_3.0.3-2~bpo50+1_amd64.deb
 861fa58ae0e539964deaf7c72a8adf5bb12d52b03c2e4dff9f871dca56a7f21b 97254 libheartbeat2-dev_3.0.3-2~bpo50+1_amd64.deb
 0099d048469de7dcda671c1f1341bbc3 1772 admin optional heartbeat_3.0.3-2~bpo50+1.dsc
 baa95df6f96d0a4fb8a399713f1352e1 619496 admin optional heartbeat_3.0.3.orig.tar.gz
 6aa7e255da08f13e902e2c1b18f6ff8d 26729 admin optional heartbeat_3.0.3-2~bpo50+1.diff.gz
 da417ef98ca70878fb0a1b256aade78d 406562 admin optional heartbeat_3.0.3-2~bpo50+1_amd64.deb
 befb1cce46ecb063ba6b6fbeb416cf8d 1074288 devel optional heartbeat-dev_3.0.3-2~bpo50+1_amd64.deb
 5cd31a2bf677417641361e83f9d1b2cd 71958 libs optional libheartbeat2_3.0.3-2~bpo50+1_amd64.deb
 384a1febba551c2d1116a4e2ec32a2e1 97254 libdevel optional libheartbeat2-dev_3.0.3-2~bpo50+1_amd64.deb

Version: GnuPG v1.4.10 (GNU/Linux)


  to pool/main/h/heartbeat/heartbeat-dev_3.0.3-2~bpo50+1_amd64.deb
  to pool/main/h/heartbeat/heartbeat_3.0.3-2~bpo50+1.diff.gz
  to pool/main/h/heartbeat/heartbeat_3.0.3-2~bpo50+1.dsc
  to pool/main/h/heartbeat/heartbeat_3.0.3-2~bpo50+1_amd64.deb
  to pool/main/h/heartbeat/heartbeat_3.0.3.orig.tar.gz
  to pool/main/h/heartbeat/libheartbeat2-dev_3.0.3-2~bpo50+1_amd64.deb
  to pool/main/h/heartbeat/libheartbeat2_3.0.3-2~bpo50+1_amd64.deb

Reply to: