[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

lyx_1.6.4-1~bpo50+1_i386.changes is NEW

(new) latex-xft-fonts_1.6.4-1~bpo50+1_all.deb extra fonts
TrueType versions of some TeX fonts -- transitional package
 This package only exists to ease the transition to the ttf-lyx package.
(new) lyx-common_1.6.4-1~bpo50+1_all.deb optional editors
Architecture-independent files for LyX
 This package contains LyX's common files which are not
 architecture-dependent. See the lyx package for a description of LyX
(new) lyx_1.6.4-1~bpo50+1.diff.gz optional editors
(new) lyx_1.6.4-1~bpo50+1.dsc optional editors
(new) lyx_1.6.4-1~bpo50+1_i386.deb optional editors
Document Processor
 LyX is an almost WYSIWYG-frontend for LaTeX. It makes the power and
 typesetting quality of LaTeX available for people who are used to
 word processors. Since LyX supports LaTeX's concept of general
 mark-ups, it is even easier and faster to create professional quality
 documents with it than with usual word processors. It is also
 possible to use LaTeX commands within LyX, so nothing of LaTeX's
 power is lost.
 You can extend the functionality of LyX by installing these packages:
  * chktex: check for typographical errors
  * dvipost: display tracked changes in DVI format output
  * gnuhtml2latex: import HTML documents
  * groff: improved table formatting in plain text exports
  * linuxdoc-tools: export SGML LinuxDoc documents
  * noweb: import noweb files
  * rcs: integrated version control
  * sgmltools-lite: export SGML DocBook documents
  * tex4ht, hevea, tth, or latex2html: export HTML documents
  * texlive-latex-extra: more styles and packages
  * wv: import MS Word documents
(new) lyx_1.6.4.orig.tar.gz optional editors
(new) ttf-lyx_1.6.4-1~bpo50+1_all.deb optional fonts
TrueType versions of some TeX fonts
 These fonts are needed for the visual math symbol display in
 LyX. They can also be used to display MathML in Gecko-based browsers
 like Iceweasel.
 The following fonts are included in this package:
  * cmex10  - Computer Modern math extension
  * cmmi10  - Computer Modern math italic
  * cmr10   - Computer Modern Roman
  * cmsy10  - Computer Modern math symbols
  * esint10 - Alternate integrals
  * eufm10  - Euler Fraktur (medium-weight)
  * msam10  - Extra math symbols, first series
  * msbm10  - Extra math symbols, second series, including Blackboard Bold
  * wasy10  - Waldi symbol fonts
Changes: lyx (1.6.4-1~bpo50+1) lenny-backports; urgency=low
  * Rebuild for lenny-backports.
lyx (1.6.4-1) unstable; urgency=low
  * New upstream release.
    - Drop patches detect-elyxer, boost-mt (applied upstream).
  * Bump Standards-Version to 3.8.3. No changes.
  * Un-versioned build-dep on boost.
  * Un-versioned build-dep on python-support.
lyx (1.6.3-5) unstable; urgency=low
  * Check if latex-xft-fonts.hints exists before purging it with defoma.
  * Add debian/gbp.conf making git-buildpackage use pristine-tar.
lyx (1.6.3-4) unstable; urgency=low
  * Make latex-xft-fonts priority extra, correcting override disparity.
  * Create all dirs with mkdir in debian/rules, so that they always
    exist even if we build arch-only. Closes: #537691.
lyx (1.6.3-3) unstable; urgency=low
  * Add Section: fonts to ttf-lyx.
  * Add latex-xft-fonts transitional package.
    - Delete old conffile /etc/defoma/hints/latex-xft-fonts.hints from
      preinst and unregister from defoma.
  * Add patch fix-manpage-errors which fixes errors in tex2lyx(1).
  * Simplify debian/rules even more by using the new dh override
    feature. Also use dh for quilt. Build-deps accordingly.
  * Improve ttf-lyx's long description, add subject to the first
    sentence. Closes: #537565.
  * Describe the fonts included in ttf-lyx in its long description.
lyx (1.6.3-2) unstable; urgency=low
  [ Sven Hoexter ]
  * Add a ttf-lyx package as replacement for the latex-xft-package.
  * Update detect-elyxer. Now all images are included in the output
  [ Per Olofsson ]
  * Update Vcs-* fields to the new Git repository.
  * Update ttf-lyx description.
  * Move fonts in debian/rules instead of deleting them and installing
lyx (1.6.3-1) unstable; urgency=low
  [ Sven Hoexter ]
  * New upstream release
   + URLs in footnotes containing '#' or '%23' work again. Closes: #529937
  * Add patches/boost-mt. Starting with boost 1.38.0 the -mt suffix in the
    soname is back so we've to modify some makefiles to let it link again.
    Closes: #530469, #533427
  * Lift Build-Depends on libboost-dev up to 1.38.0 - otherwise the
    boost-mt patch will be harmful.
  * Add debian/patches/detect-elyxer. Modifies configure.py to search
    for 'elyxer' and 'elyxer.py'.
  * Update Standards-Version to 3.8.2 - no changes required.
  [ Per Olofsson ]
  * Update debian/watch URL.
lyx (1.6.2-1) unstable; urgency=low
  [ Per Olofsson ]
  * Add ghostscript and poppler-utils to Recommends. Closes: #515914
  [ Sven Hoexter ]
  * New upstream release Closes: #519936
  * Update Standards-Version to 3.8.1 without any changes.
  * Move the -e flag in the (post|pre)inst scripts from the shebang
    line to a separate 'set -e'. This is useful if you run the scripts
    with a different shell for debugging purpose.
lyx (1.6.1-1) unstable; urgency=low
  [ Per Olofsson ]
  * Don't recommend postscript-viewer. Those who need one know how to get
    it, and a PDF reader is enough for most people.
  [ Sven Hoexter ]
  * New upstream release
    + Add missing includes for cstdio as it won't be included indirectly
      in gcc 4.4. Thanks to Martin Michlmayr. Closes: #505958
  * Add ${misc:Depends} to the Depends field for the lyx binary package.
    This seems to be a required thing nowdays (according to lintian).
  * Move texlive-latex-extra from Suggests to Recommends. Closes: #499629
lyx (1.6.0-1) unstable; urgency=low
  [ Sven Hoexter ]
  * New upstream release
    + Fix for 'word-delete' deletes following non-word items. Closes: #492841
    + URL export works again. Closes: #344677
    + Fix for tables stopped working in g-brief-de. Closes: #379747
  * Change the name of the license file on Debian system from GPL to GPL-2.
  * Refresh /patches/prefer-xdg-open.
  * Replace the old LyX logo with the new one. Converted from the
    lib/images/lyx.png file to 32x32 XPM file.
  * Remove empty /usr/share/lyx/images/commands directory from lyx-common.
  [ Per Olofsson ]
  * Remove texlive-latex-base dependency from lyx-common, as it already
    depends on tex-common via ${misc:Depends}, and that's all that's
    really necessary.
  * Remove debian/lyx-common.postrm. It was only deleting /etc/lyxrc,
    which is not necessary since the file is deleted in preinst.
  * Don't remove profiling.py, there's no reason.
lyx (1.6.0~beta4-1) experimental; urgency=low
  [ Sven Hoexter ]
  * New upstream release resolves the following bugs:
    + lyx invokes xdvi without landscape options for landscape docs
      Closes: #269968
  * Don't try to install the top-level ChangeLog as changelog.gz.
  [ Per Olofsson ]
  * Use new features in debhelper v7 to shorten debian/rules.
  * Misc improvements to debian/rules.
  * Point to new lyx icon in png format from /usr/share/icons.
  * Use dh_installtex to update ls-R files from maintainer scripts. Will do
    it faster than plain texhash.
  * Remove now-useless versioned build-deps.
  * Suggest cups-client instead of cupsys-client.
  * Add debian/README.source.
  * Bump Standards-Version to 3.8.0.
  * Remove the -ffunction-sections workaround on hppa and let's hope it
    works. I can't test because there are no DD-accessible hppa machines
    at the moment.

Override entries for your package:

Announcing to backports-changes@lists.backports.org

Your package contains new components which requires manual editing of
the override file.  It is ok otherwise, so please be patient.  New
packages are usually added to the override file about once a week.

You may have gotten the distribution wrong.  You'll get warnings above
if files already exist in other distributions.
st in other distributions.

Reply to: