[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted neko 1.8.0-4~bpo50+1 (source all i386)

Hash: SHA1

Format: 1.8
Date: Sun, 19 Apr 2009 20:48:24 +0100
Source: neko
Binary: libneko0 neko-dev neko libapache2-mod-neko
Architecture: source all i386
Version: 1.8.0-4~bpo50+1
Distribution: lenny-backports
Urgency: low
Maintainer: Jens Peter Secher <jps@debian.org>
Changed-By: Jens Peter Secher <jps@debian.org>
 libapache2-mod-neko - Apache module for running server-side Neko programs
 libneko0   - Lightweight virtual machine - shared library
 neko       - Lightweight virtual machine - compiler and tools
 neko-dev   - Lightweight virtual machine - development
Closes: 406033 412567 414123 415803 429139 437609 509454
 neko (1.8.0-4~bpo50+1) lenny-backports; urgency=low
   * Backport to Lenny.
 neko (1.8.0-4) unstable; urgency=low
   * Fix broken NDLLs (shared libraries) by reverting some of the previous
 neko (1.8.0-3) unstable; urgency=low
   * Fix build failure on MIPS by tightening up the linking process.
   * Make neko-dev architecture independent since there are no binary files
     in neko-dev.
   * Bumped the Standards-Version to 3.8.1.
 neko (1.8.0-2) unstable; urgency=low
   * Promoted libneko to a proper shared library living in /usr/lib.
     (Closes: #509454)
   * No need to Build-Conflict with itself because all rpaths have been
   * Use quilt instead of dpatch for patches, and describe how to use
     quilt in Debian.source (thanks to Russ Allbery).
   * Strip all shared libraries.
   * Put test.n and test.neko in examples directory.
   * Added a Vcs-Hg control filed to indicate the location of the public
   * Bumped the Standards-Version to 3.8.0.
 neko (1.8.0-1) experimental; urgency=low
   * New upstream release.
   * Bumped debhelper version to 6.
 neko (1.7.1-1~bpo40+1) etch-backports; urgency=low
   * Backport to Etch (no change).
 neko (1.7.1-1) unstable; urgency=low
   * New upstream release.
   * Call dh_makeshlibs before dh_installdeb in debian/rules.
   * Define _GNU_SOURCE to get threads to work.
 neko (1.7.0-1) unstable; urgency=low
   * New upstream release.
 neko (1.6.0-4~bpo40+2) etch-backports; urgency=low
   * Pass version extracted by dpkg-parsechangelog to dh_makeshlibs instead
     of error prone hard-coding.
 neko (1.6.0-4~bpo40+1) etch-backports; urgency=low
   * Without the Homepage field.
 neko (1.6.0-4) unstable; urgency=low
   * Give libneko a proper SONAME to avoid breakage by new dpkg-shlibdeps.
   * Avoid a lot of unnecessary shared library dependencies.
   * Place the apache module in section web.
   * Use the Homepage field in the control file.
   * Bump debhelper to version 5.
 neko (1.6.0-3) unstable; urgency=low
   * Fixed missing reference to shared mysqlclient library.
 neko (1.6.0-2~bpo40+1) etch-backports; urgency=low
   * Backport to Etch (no change).
 neko (1.6.0-2) unstable; urgency=low
   * Support non-stripped builds (DEB_BUILD_OPTIONS=nostrip).
     (Closes: #437609)
 neko (1.6.0-1) unstable; urgency=low
   * New upstream release, which obsoletes 75-kfreebsd-defines.dpatch and
     incorporates 50-embed-endianess.dpatch .
   * New build-depends libgtk2.0-dev.
   * Update man pages.
 neko (1.5.3-6) unstable; urgency=low
   * Drop support for obsolete Apache 1.
     (Closes: #429139)
   * Provide Apache 2 module as seperate package.
 neko (1.5.3-5bpo1) stable; urgency=low
   * Backport to Etch (no change).
 neko (1.5.3-5) unstable; urgency=low
   * Compile with -DEAPI.
     (Closes: #415803)
 neko (1.5.3-4) unstable; urgency=low
   * Fix FTBFS on GNU/kFreeBSD, thanks to Cyril Brulebois.
     (Closes: #414123)
 neko (1.5.3-3) unstable; urgency=low
   * Fix endianess problem in embedded-code loader.
     (Closes: #412567)
 neko (1.5.3-2) unstable; urgency=low
   * It turned out that binaries cannot really be stripped, so no
 neko (1.5.3-1) unstable; urgency=low
   * New upstream release.
   * The bootable vm implementation changed, so now binaries are now
     stripped, and the aligment patch has become obsolete.
 neko (1.5.2-3) unstable; urgency=low
   * Fix build failure on various architectures by aligning bytecode at 16
     byte offset.
     (Closes: #406033)
 neko (1.5.2-2) unstable; urgency=low
   * Neko modules now work for non-threaded Apache 2.2, that is, it works
     for apache2-mpm-prefork.
 neko (1.5.2-1) experimental; urgency=low
   * New upstream release.
   * Unfortunately Apache 2.2 still hangs when serving Neko files, but I am
     leaving the setup in case others figure out why.
   * Build-Conflicts with itself because the hardcoded rpath gets in the
     way when different versions of the VM do not agree.
 neko (1.5-3) experimental; urgency=low
   * Register Apache 1.3 module automatically if Apcahe is installed.
   * Register Apache 2.2 modules automatically if Apcahe is installed.
 neko (1.5-2) experimental; urgency=low
   * Note to ftpmasters: Neko is written in Neko, so the files boot/* are
     needed to bootstrap the compiler.  The source for them is in src/*.
 neko (1.5-1bpo1) stable; urgency=low
   * Fit dependencies and include directories so that is is possible to
     backport to sarge.
 neko (1.5-1) experimental; urgency=low
   * Manpages written for the three executable.
   * The executables searches for the libneko.so by use of -rpath in
     /usr/lib/neko since we do not want this private library to end up in
   * The dynamic modules /usr/lib/neko/*.ndll are not stripped because they
     are created as concatenations of the virtual machine bootloader and
     some bytecode, which makes stripping impossible (cf. OCaml Packaging
     Policy).  Lintian overrides included for not stripping.
   * The additional Apache modules are placed in /usr/lib/neko, but not
     registered with Apache automatically, which avoids a dependency on
     Apache until we have made proper arrangements with the Apache team.
 df952ae5311aadb15a4842d9e4a6d3502cf41fca 1324 neko_1.8.0-4~bpo50+1.dsc
 ad9d86f780e4b1442326aae2abf38736b433826f 402210 neko_1.8.0.orig.tar.gz
 fa4c6586af730acffdafb8857d1506c4cb9a61ec 9051 neko_1.8.0-4~bpo50+1.diff.gz
 4951e8344632cf842843145c55b6c9e50e54f7be 9626 libapache2-mod-neko_1.8.0-4~bpo50+1_all.deb
 c1d5df08cbbf37f48662ae01544d7abff4fbc27c 13580 neko-dev_1.8.0-4~bpo50+1_all.deb
 c0fbe972ae6768b09fe9ec8573e0d48c8b753edb 65768 libneko0_1.8.0-4~bpo50+1_i386.deb
 a8b2c1f4875822fac691be2387eb18187fcec81a 214316 neko_1.8.0-4~bpo50+1_i386.deb
 2cfc675104ed76940f31515f2c3f9d5830cc6f78cd3460479526a28286e8ed5f 1324 neko_1.8.0-4~bpo50+1.dsc
 7a71c9cf3177c14e5afc114f060d43c4056cca8afa80ab08bdc76b83fdf803d3 402210 neko_1.8.0.orig.tar.gz
 7b63dd8e8b5955ad0ee072238467198ca487c28a5ebb7ac8891df11d4feaa1c1 9051 neko_1.8.0-4~bpo50+1.diff.gz
 ffc9bdc9ce826ccec9415f15ce6a43e3c2e61cdafbe289b4726c77a4e58d5699 9626 libapache2-mod-neko_1.8.0-4~bpo50+1_all.deb
 7c2d033fff6d38006cfa247c1e99e0549b1b88adaaf7dd15b16027f567eac720 13580 neko-dev_1.8.0-4~bpo50+1_all.deb
 060a75078f0ac9175899a6028fe10cec1f26ebd91eac50a843ed089824767af9 65768 libneko0_1.8.0-4~bpo50+1_i386.deb
 9d236d540d9d73e0683522e9ee2a0af206d77267867ec7e7847efb7fb2bde4f7 214316 neko_1.8.0-4~bpo50+1_i386.deb
 19ecae98b5403a97006ed4ae430e158e 1324 interpreters optional neko_1.8.0-4~bpo50+1.dsc
 b41da79e6f976818ab64805e9ba7298c 402210 interpreters optional neko_1.8.0.orig.tar.gz
 e82be02e0feb98f0bb2fa575a5cd2031 9051 interpreters optional neko_1.8.0-4~bpo50+1.diff.gz
 c15169817251ae32d10554470c069caa 9626 web optional libapache2-mod-neko_1.8.0-4~bpo50+1_all.deb
 23628fb66a52f5516a37b655142f9c27 13580 libdevel optional neko-dev_1.8.0-4~bpo50+1_all.deb
 ae56d9c1cfb6e296f4e2906c12204dee 65768 libs optional libneko0_1.8.0-4~bpo50+1_i386.deb
 8f9eecad44df31b684c4b63b1aa9e216 214316 interpreters optional neko_1.8.0-4~bpo50+1_i386.deb

Version: GnuPG v1.4.9 (GNU/Linux)


  to pool/main/n/neko/libapache2-mod-neko_1.8.0-4~bpo50+1_all.deb
  to pool/main/n/neko/libneko0_1.8.0-4~bpo50+1_i386.deb
  to pool/main/n/neko/neko-dev_1.8.0-4~bpo50+1_all.deb
  to pool/main/n/neko/neko_1.8.0-4~bpo50+1.diff.gz
  to pool/main/n/neko/neko_1.8.0-4~bpo50+1.dsc
  to pool/main/n/neko/neko_1.8.0-4~bpo50+1_i386.deb
  to pool/main/n/neko/neko_1.8.0.orig.tar.gz

Reply to: