[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted mod-wsgi 2.3-1~bpo40+1 (source amd64)



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Thu, 04 Sep 2008 01:33:00 +0200
Source: mod-wsgi
Binary: libapache2-mod-wsgi
Architecture: source amd64
Version: 2.3-1~bpo40+1
Distribution: etch-backports
Urgency: medium
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Changed-By: Bernd Zeimetz <bzed@debian.org>
Description: 
 libapache2-mod-wsgi - Python WSGI adapter module for Apache
Closes: 443105 445486 456737 483197 483197 488982 491478 496067
Changes: 
 mod-wsgi (2.3-1~bpo40+1) etch-backports; urgency=low
 .
   * Rebuild for etch-backports.
 .
 mod-wsgi (2.3-1) unstable; urgency=low
 .
   * New upstream release (Closes: #496067). This upload covers the changes of
     mod-wsgi 2.2 and 2.3.
     mod-wsgi 2.2 is mainly bugfix-releases. The only exception is a backport
     of one function from 3.0 which allows the setting of process names on *BSD
     - this does not affect Linux.
     mod-wsgi 2.3 fixes regressions which were introduced in 2.2.
 .
     Here follows a list of the bugfixes in 2.2:
       1. Fix bug whereby if mod_python is loaded at same time as mod_wsgi the
          WSGIImportScript directive can cause Apache child processes to crash.
          For details see: http://code.google.com/p/modwsgi/issues/detail?id=91
 .
       2. Fix bug where mod_wsgi daemon process startup could fail due to old
          stale UNIX listener socket file as described in:
          http://code.google.com/p/modwsgi/issues/detail?id=77
 .
       3. Fix bug where listener socket file descriptors for daemon processes
          were being leaked in Apache parent process on a graceful restart.
          Also fixes problem where UNIX listener socket was left in filesystem
          on both graceful restart and graceful shutdown. For details see:
          http://code.google.com/p/modwsgi/issues/detail?id=95
 .
       4. Fix bug where response was truncated when a null character appeared
          as first character in block of data being returned from
          wsgi.file_wrapper.
          Only occurred when code fell back to using iteration over supplied
          file like object, rather than optimised method such as sendfile().
          http://code.google.com/p/modwsgi/issues/detail?id=100
 .
     The following regressions/bugs of 2.2 were fixed in 2.3:
 .
       1. Fixed problem introduced in version 2.2 of mod_wsgi whereby use of
          daemon mode would cause CGI scripts to fail. It is quite possible
          that the bug could also have caused failures with other Apache
          modules that relied on registering of cleanup functions against
          Apache configuration memory pool.
 .
       2. (does not affect Linux)
          When using setproctitle() on BSD systems, first argument should be
          a printf style format string with values to fill out per format as
          additional arguments. Code was supplying value to be displayed as
          format string which meant that if it contained any printf type format
          sequences, could cause process to crash as corresponding arguments
          wouldn't have ben provided.
 .
 mod-wsgi (2.1-2) unstable; urgency=medium
 .
   * Calling pyversions in postinst requires that 'python' is installed *and*
     configured, so it would need to be added to Pre-Depends. As this is kinda
     ugly, we ship the symlink to the module for the right Python version now
     in the package. I assume that this will really fix #483197 now, I'm quite
     sure that the broken link results from an error message of the
     unconfigured python/pyversions. Shipping the symlink also makes sure that
     it is available while Apache is configured (which may happen before
     mod-wsgi is configured). (Closes: #483197, #491478)
   * Drop the parts from the maintainer scripts which renamed the wsgi config
     files (see #456737 for details) - as mod-wsgi was not released with Etch
     and the fix was for a long enough time in testing, it should be safe to
     remove them before Lenny.
 .
 mod-wsgi (2.1-1) unstable; urgency=low
 .
   * New upstream release.
   * debian/libapache2-mod-wsgi.rtupdate:
     - Fixing bashism. Thanks to Vitaliyi (Closes: #483197)
   * debian/copyright:
     - Removing full text of the Apache License, linking to
       /usr/share/common-licenses/Apache-2.0 instead.
   * debian/wsgi.conf:
     - Removing WSGIPythonExecutable directive from the example configuration
       as it does not exist in 2.X versions of mod-wsgi. Thanks to Martin
       Tomasek for the report. (Closes: #488982)
 .
 mod-wsgi (2.0-1) unstable; urgency=low
 .
   * New upstream version.
   * Merging changes of the experimental uploads.
 .
 mod-wsgi (2.0~c5-1) experimental; urgency=low
 .
   * New beta version.
   * debian/control:
     - Updating my email address.
 .
 mod-wsgi (2.0~c4-2) experimental; urgency=low
 .
   * Rename mod_wsgi.load to wsgi.load to follow
     /etc/apache2/mods-available best practise (sync with 1.3-2 from unstable)
 .
 mod-wsgi (1.3-2) unstable; urgency=low
 .
   [ Sandro Tosi ]
   * debian/control
     - uniforming Vcs-Browser field
 .
   [ Piotr Ożarowski ]
   * Rename mod_wsgi.load to wsgi.load (to follow
     /etc/apache2/mods-available best practise, closes: 456737)
   * Bump Standards-Version to 3.7.3 (no changes needed)
   * Add myself to Uploaders
 .
 mod-wsgi (2.0~c4-1) experimental; urgency=low
 .
   * New beta version.
   * debian/control:
     - Updating my email address.
     - Updating Standards-Version to 3.7.3.
 .
 mod-wsgi (2.0~c3-1) experimental; urgency=low
 .
   * New beta version.
 .
 mod-wsgi (1.3-1) unstable; urgency=low
 .
   * New upstream version
 .
 mod-wsgi (2.0~c2-1) experimental; urgency=low
 .
   * New beta version.
   * debian/patches:
     - Removing ap_thread_stacksize.dpatch as the issue is fixed by upstream
       now.
 .
 mod-wsgi (2.0~c1-2) experimental; urgency=low
 .
   * debian/control: reverting the change from -1
   * debian/patches:
     - Adding ap_thread_stacksize.dpatch to allow us to build the module using
       apache-threaded-dev. In the rare case that somebody would like to
       configure the stack size of WSGIDaemonProcess, both ThreadStackSize and
       stack-size option need to be set due to this change.
       Thanks to the upstream author, Graham Dumpleton.
 .
 mod-wsgi (2.0~c1-1) experimental; urgency=low
 .
   [ Bernd Zeimetz ]
   *  Beta version of the upcoming 2.0 version.
 .
   [ Piotr Ożarowski ]
   * debian/control:
     - move "apache2-mpm-worker | apache2-mpm-event" from Suggests to Depends
       as 2.0~c1 doesn't work with apache2-mpm-prefork
 .
 mod-wsgi (1.2-1) unstable; urgency=low
 .
   * New upstream version
   * debian/watch:
     - Only watching for updates of released versions now, beta versions go
       into an experimental branch.
 .
 mod-wsgi (1.1-2) unstable; urgency=low
 .
   * Applying a patch from Josselin Mouette - thanks, introducing the
     following changes
     - Build the module for all supported python versions.
     - Ship a rtupdate script to rotate to the new version when the python
       version changes.
     - Build-depend on python-all-dev.
     (Closes: #445486)
 .
   * debian/control:
     - Renaming XS-Vcs-* fields to Vcs-*, as they're supported by dpkg now
 .
 mod-wsgi (1.1-1) unstable; urgency=low
 .
   * New upstream version
   * debian/control:
     - Adding Homepage field, removing pseudo-field from description
 .
 mod-wsgi (1.0-2) unstable; urgency=low
 .
   * debian/control:
     - Moving apache workers from Recommends to Suggests to make the package
       installation more easy for those who really want to use PHP, which
       depends on the preforking worker (Closes: #443105).
     - Adding apache2 to Depends
 .
 mod-wsgi (1.0-1) unstable; urgency=low
 .
   * New upstream version - first stable release.
   * debian/watch:
     - Small fix to recognize versions correctly
 .
 mod-wsgi (1.0~c4-1) unstable; urgency=low
 .
   * New upstream version
   * debian/patches:
     - Removing r413-error-log-fix.dpatch as this fix is included in the
       upstream tarball
 .
 mod-wsgi (1.0~c2-1) unstable; urgency=low
 .
   * New upstream version
   * debian/control:
     - Removing autotools-dev build-dep, as configure relies on the information
       provided by apxs2 and does not take care of config.sub or config.guess.
   * debian/watch:
     - Fixing filenamemangle to allow uscan to download the file
   * debian/patches/makefile-destdir.dpatch,umask-fix.dpatch:
     - Removing files, changes were added upstream
   * debian/patches/r413-error-log-fix.dpatch:
     - Adding patch from upstream's svn to fix a bug which could result in a
       crash of mod-wsgi, for details see
       http://code.google.com/p/modwsgi/issues/detail?id=24
 .
 mod-wsgi (1.0~c1-2) unstable; urgency=low
 .
   * debian/mod-wsgi.conf:
     - Adding a config file for mod-wsgi to allow easy configuration for users
   * debian/control:
     - Adding apache2-mpm-worker | apache2-mpm-event as Recommends to provide a
       fast default worker
Files: 
 e7b822c63dca9037133ce777389856b1 755 python optional mod-wsgi_2.3-1~bpo40+1.dsc
 c686e1c498dbe5753fe491c3cf61cff4 96872 python optional mod-wsgi_2.3.orig.tar.gz
 cb08c0fa625523454025a4e95640cc36 11055 python optional mod-wsgi_2.3-1~bpo40+1.diff.gz
 2253ba0a1bb4d0b60b15b40ab29d0863 68202 python optional libapache2-mod-wsgi_2.3-1~bpo40+1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAki/IAsACgkQBnqtBMk7/3mv1gCfedpNhBa+24ken73P+EtUOEdk
BBgAn1BL/YOXSkXzzrXK8JQvzTzS9Dqf
=nTsc
-----END PGP SIGNATURE-----


Accepted:
libapache2-mod-wsgi_2.3-1~bpo40+1_amd64.deb
  to pool/main/m/mod-wsgi/libapache2-mod-wsgi_2.3-1~bpo40+1_amd64.deb
mod-wsgi_2.3-1~bpo40+1.diff.gz
  to pool/main/m/mod-wsgi/mod-wsgi_2.3-1~bpo40+1.diff.gz
mod-wsgi_2.3-1~bpo40+1.dsc
  to pool/main/m/mod-wsgi/mod-wsgi_2.3-1~bpo40+1.dsc
mod-wsgi_2.3.orig.tar.gz
  to pool/main/m/mod-wsgi/mod-wsgi_2.3.orig.tar.gz


Reply to: