[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Backports-security-announce] Security Update for proftpd-dfsg

Francesco Paolo Lovergine uploaded new packages for proftpd-dfsg which
fixed the following security problem:

CVE-2008-4242, Debian Bug #502674

  ProFTPD 1.3.1 interprets long commands from an FTP client as multiple
  commands, which allows remote attackers to conduct cross-site request
  forgery (CSRF) attacks and execute arbitrary FTP commands via a long
  ftp:// URI that leverages an existing session from the FTP client
  implementation in a web browser. 

For the etch-backports distribution the problem has been fixed in
version 1.3.1-15~bpo40+1.

For the lenny and sid distributions the problem has been fixed in
version 1.3.1-15.

Upgrade instructions

If you don't use pinning (see [1]) you have to update the packages
manually via "apt-get -t etch-backports install <packagelist>" with the
packagelist of your installed packages affected by this update.
[1] <http://backports.org/dokuwiki/doku.php?id=instructions>

We recommend to pin the backports repository to 200 so that new versions
of installed  backports will be installed automatically:

  Package: *
  Pin: release a=etch-backports
  Pin-Priority: 200

Attachment: signature.asc
Description: Digital signature

Reply to: