[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: latency test results for armhf vs arm64?

On 7/16/22 05:59, Paul Wise wrote:
On Fri, 2022-07-15 at 23:05 -0400, gene heskett wrote:

The whole install of raspios is armhf. So I guess its yes.
I seem to remember them switching to arm64 recently?

They may have, I've had a total loss of history here with 2, 2T seagate
drives dieing within a couple weeks of each other. So let me see if I have
the bullseye image for arm I've tried.  Yes, and its:
Which ran fine, even with my now 2 yo kernel installed but the python
is too new for linuxcnc. With a second user wanting to dup what I did,
I've sent him two cards with the raspios buster for armhf, with my kernel
installed by my method. Linuxcnc has been advised of the python showstopper,
and that may have been fixed by now, but if so, its not caught my attention
in the email's I get from a 4x a day git pull keeping the pi up to date.

Since that master is now in testing for bookworm, I have to assume it has been fixed.

I also have 11-2 of yours, in netinstall flavor and labeled as armhf. As I recall
it had some sort of a showstopper, and I knew raspios worked, I don't recall
that  I investigated yours further. Is there a later netinstall for armhf or arm64
available now? u-sd cards I have.
I have not tried to build an aarch64 from the src I have.
I think, since the 240G I'm using for workspace is over 50% full, that I had better replace the 120G I've used for a backup, with a 1T and copy the 240 to it, before I do anything rash. That can be done but I'm in the middle of rebuilding a Prusa MK3S with a better print head and that has priority at the moment. I am using it to make the nuts for a woodworkers workbench vises, carving the screw from a 2x2" stick of hard maple about 20" long. See version #1 on my web page it the sig. Reshaping the threads for a lot better fit, version #5 is waiting on a working printer to make
more nuts.
I think it would be helpful if someone with an RPi4 could do this.
That's probably me but its also likely a week on down the log.

It, latency-test, has recently been worked on but I've not tested
it on a Debian image of either flavor since. It is now in testing so
those of you w/o 5 years of history to lose could try it for the price of a 64G u-sd card.
For those of you who are able to try this, sounds like you just install
linuxcnc-uspace and then run latency-test. Also install/try latencytop,
although Linux CONFIG_LATENCYTOP is not enabled in Debian probably.

$ apt-file search latency-test
linuxcnc-uspace: /usr/bin/latency-test
linuxcnc-uspace: /usr/share/doc/linuxcnc/examples/sample-configs/apps/latency/latency-test.demo
linuxcnc-uspace: /usr/share/man/man1/latency-test.1.gz

latencytop I've heard of, but haven't found, so no comparison comment.

Cheers, Gene Heskett.
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author, 1940)
If we desire respect for the law, we must first make the law respectable.
 - Louis D. Brandeis
Genes Web page <http://geneslinuxbox.net:6309/>

Reply to: