[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to install Bullseye on Cubox-i4Pro on USB or eSATA disk?

On 2021-07-07, Rick Thomas wrote:
> I recently tried installing the two-part image for MX6_Cubox-i from
> [1] on my Cubox-i4Pro.

I'm pretty sure while debugging #982270 (ethernet on imx6 systems), I
managed to get a successfull install to eSATA, though not *positive*
(maybe I just got as far as testing ethernet).

> It worked fine when I installed to an SD card -- I used a 32 GB card
> for the installer and installed to that same card.  But that's kinda
> limited.  The box has USB and eSATA ports that I'd like to be able to
> use, if only because they should be faster than the SD card.

Yeah, I'm running bullseye on a cubox-i4pro from eSATA.

How are you powering your eSATA? I use a eSATA+USB-power adapter to plug
in the SSD, and I'm not sure if it is still required, but I have a
boot.scr on a bootable partiton on microSD which basically does:

  sleep 1
  usb start
  sleep 3

which powers up the USB and then the eSATA has power via the USB, and
allows u-boot to load the kernel+initrd+dtb directly off of a /boot
partition on the eSATA SSD.

You can find this type of cable:


This looks pretty much just like the one I have:


I don't have a link for the exact one I have.

For a more power-hungry disk, you might need an externally powered eSATA
cable adapter instead... almost no experience with that.

> Ideally, the configuration I would like to have is system (root and
> /home) reside on a 32GB USB flash stick, if necessary with /boot on an
> SD card, but ideally with /boot on the USB stick as well.

That sounds less ideal than eSATA, but whatever floats your boat. :)

> I tried doing an "expert" install with manual disk partitioning --
> putting /boot on the SD card and root and /home on the USB stick --
> but when it rebooted it just hung, even after power-cycling.

What do you mean by "hung"? U-boot never displays on the serial console?
U-boot hangs at some point?  U-boot loads the kernel+initrd+dtb and it's
stuck at "Starting kernel..."? The kernel loads and prints messages but
the initramfs never finds the rootfs?

A boot log would be very useful here. :)

> Same thing happened when I did a "guided" partitioning install with
> all partitions (/boot, root, and /home) on the USB stick.

I haven't worked with USB rootfs much on the cubox-i precisely because
eSATA is a better interface, but depending on where exactly it hung,
maybe you're missing modules in the initramfs...

live well,

Attachment: signature.asc
Description: PGP signature

Reply to: