[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Issues installing libc6:arm64 on amd64

Yes, you are right. 

I am on unstable. And indeed it was package version mismatch in the repository. I wish apt was clear what is wrong :)

It works now!

I will switch to testing probably to have less issues with version mismatch.


On Fri, 20 Nov 2020, 18:16 John Paul Adrian Glaubitz, <glaubitz@physik.fu-berlin.de> wrote:
Hello Witold!

On 11/20/20 3:44 PM, Witold Baryluk wrote:
> I tried the same with `armhf`, and apt install libc6:armhf
> libgcc-s1:armhf gcc-10-base:armhf , installed without issues.
> Any help? Is this some transient issue with the repository?

I assume that you are doing this on Debian unstable as the package versions
indicate - posting your sources.list would help clarifying this question.

In unstable, package versions are constantly changing and for MultiArch to
work, the version numbers of library packages that are being co-installed
have to match.

I have not looked into the versions of the packages in question right now,
but the problem will simply be that any of the packages you are trying to
install, directly or through dependencies, are out of sync, either because
the arm64 buildds have not kept up with amd64 for any of the packages yet
or one of the packages in question failed to build from source.

So, to resolve this problem, use either stable or testing where packages can
not become out of sync or just wait for this transient situation to settle.


 .''`.  John Paul Adrian Glaubitz
: :' :  Debian Developer - glaubitz@debian.org
`. `'   Freie Universitaet Berlin - glaubitz@physik.fu-berlin.de
  `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913

Reply to: