[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: openssl sha1 not working with large files on stretch arm.

On 2019-04-11 23:15:45 [+0200], Kurt Roeckx wrote:
> On Thu, Apr 11, 2019 at 04:51:50PM -0400, Jeffrey Walton wrote:
> > On Thu, Apr 11, 2019 at 11:24 AM peter green <plugwash@p10link.net> wrote:
> > >
> > > I got a report from a user about "openssl sha1 <filename>" not working for large files on raspbian stretch.
> > >
> > > I investigated the problem and found that when I tried to use "openssl sha1 <filename>" for a large (>2GB) file on Debian armhf stretch or raspbian stretch I get an error "Value too large for defined data type"
> > >
> > >
> > > What puzzles me is that it worked on raspbian buster, and also worked on debian stretch i386. According to the user who reported it to me it  worked on Raspbian jessie. Anyone have any clues? I'm not finding anything obvious in the build logs or from a quick look at the source (it seems a couple of source files are built with large file support and the rest are not, but which files doesn't seem to have changed between stretch and buster).
> > >
> > 
> > Likely coming from the shell and not OpenSSL; see
> > https://serverfault.com/q/735636/145545.
> > 
> > Maybe coreutils changed something recently.
> Note that is just the string for strerror(EOVERFLOW). It could be
> that we use something like fstat() and get that errno.

strace should reveal where it is coming from.

> Kurt


Reply to: