[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: QNAP TS419: Wake-On-Lan not working - Solved

Hi again,

I forgot about qcontrol, as it was not necessary to activate wol this way for a long time. After starting qcontrol -d and sending
   qcontrol wol on
it is working again (even without running qcontrol as a daemon after the next boot). Possibly during installing the serial interface the ethernet controller was reset.

So for the moment, the problem is solved!


Am 15.05.2018 um 14:47 schrieb Hartmut:
Hi all,

I'm running Debian 6.3.0-18 on a TS419U+ which is a huge improvement over the stock firmware - many thanks to all who have worked on it!

Wake-on-lan was running fine until an update. I just ran apt-get upgrade again, but it didn't solved the problem. Unfortunately, I cannot tell in which moment it stopped working. The current kernel is
    kernel 4.9.0-3-marvell #1 Debian 4.9.30-2+deb9u5 (2017-09-19)

ethtool reports wol is set, see 1) but I'm wondering why the link is not detected, since in the interface is active and hwinfo reports
   Link detected: yes

How can I get wol back working? It is essential, as the server is usually started remotely for backups.

One thing I should mention: I've attached a serial console some months ago which is working fine. Could this brake wol?

Many thanks,


1) Settings for eth0:
         Supported ports: [ TP MII ]
         Supported link modes:   10baseT/Half 10baseT/Full
                                 100baseT/Half 100baseT/Full
         Supported pause frame use: No
         Supports auto-negotiation: Yes
         Advertised link modes:  10baseT/Half 10baseT/Full
                                 100baseT/Half 100baseT/Full
         Advertised pause frame use: No
         Advertised auto-negotiation: Yes
         Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                              100baseT/Half 100baseT/Full
                                              1000baseT/Half 1000baseT/Full
         Link partner advertised pause frame use: No
         Link partner advertised auto-negotiation: No
         Speed: 1000Mb/s
         Duplex: Full
         Port: MII
         PHYAD: 0
         Transceiver: external
         Auto-negotiation: on
         Supports Wake-on: g
         Wake-on: g
         Link detected: no

Reply to: