[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: QNAP TS-209II make bootable fails

* John Roberts <johnr@iinet.net.au> [2016-02-28 18:33]:
> I have tried to install Debian on to my QNAP TS-209II using the guided
> installation but the make bootable step has failed on several attempts
> despite keeping installed packages to a minimum.
> I assume the flash size is too low for this to work for the current release
> but this is a non evidence based guess.
> I can still login using the user installer with associated password and get
> the "ash" shell. Can anyone spell out how to make it bootable when the power
> switch is turned on?
> On device #0 I have
> #1 primary ext2 /boot.
> #2 primary ext2 /
> #5 logical    swap

So you didn't use RAID or LVM?  In that case, it should work, or at
least it worked for me.

You can open a shell and look at /var/log/syslog to see why it failed.

If it's size related, do:
  echo "COMPRESS=xz" > /target/etc/initramfs-tools/conf.d/compress
and run the installer step to make it bootable again.

And BTW, I suggest you use ext4 rather than ext2.

Martin Michlmayr

Reply to: