[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: System crashes on USB connection

Thank you for all the input. I had more time to try this and found that connecting the USB cable while the printer is turned on while cause the NAS to crash. If I turn on the printer after having plugged in the cable (like in normal operation), this gets no problem.

30.11.2012 09:21, Christoph Zep wrote:
Sorry for the delayed answer. I tried this and indeed, the NAS booted:

[   24.418570] usb-storage: device found at 3
[   24.418577] usb-storage: waiting for device to settle before scanning
[ 24.492029] usb 1-1.3: new high speed USB device using orion-ehci and address 4 [ 24.602999] usb 1-1.3: New USB device found, idVendor=04a9, idProduct=1730 [ 24.603025] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   24.603043] usb 1-1.3: Product: MP540 series
[   24.603054] usb 1-1.3: Manufacturer: Canon
[   24.603064] usb 1-1.3: SerialNumber: A25E45
[   24.604083] usb 1-1.3: configuration #1 chosen from 1 choice
[   24.607279] scsi1 : SCSI emulation for USB Mass Storage devices
[   24.610269] usb-storage: device found at 4
[   24.610277] usb-storage: waiting for device to settle before scanning
[   29.411933] usb-storage: device scan complete

After this, I could even turn the printer on and off without Debian crashing / freezing.

The only other thing I changed since my last try is that I removed CUPS. I will report back here as soon as I had the time to try it a few more times, hopefully with a little bit of printing. Maybe the two times that I experienced the freezing were really only bad luck when connecting the cable while printer and NAS were running?

26.11.2012 16:10, Brian Platt wrote:
> Date: Mon, 26 Nov 2012 00:53:37 +0100
> From: debian-arm@quantentunnel.de
> To: debian-arm@lists.debian.org
> Subject: System crashes on USB connection
> Hi everyone,
> I installed Debian on a USB flash drive on my QNAP TS-419p+(Kirkwood)
> inserted into the lowest backside USB port.Everything's been working
> very smoothly until I tried to connect my printer to the NAS (also via
> USB). Via SSH the NAS reacted with the same error to every command as
> soon as the printer was connected:
> -bash: /bin/dmesg: Input/output error
> Upon manual power off (button on the NAS) and reboot, the system took a
> very long time to come up and finally booted. Since then, the system
> boots quickly againbut I don't know how to get my printer working.
> Thanks for any suggestions,
> Christoph

Does it work if you plug both devices in while it's powered off and then power it on?

Reply to: