[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

QNAP TS219 poweroff problem

Hi All,

I have Debian squeeze running on my TS219 since a few days thanks to the
excellent installation manual from Martin.

Yesterday I have tried to play around with WOL. Therefore I implemented
the missing phy bits in the mv643xx_eth driver and added the wol
commands to qcontrol (for now).

When I was ready to try things out, I noticed that my TS219 will not
poweroff. I tried "poweroff" or "shutdown -h now" but the machine kept
powered on. The system shuts down (as far as I can see having no serial
console attached) and the moment the poweroff command is send to the
pic, the fan runs full speed for a second and keeps running silently and
the power led flashes red / green.

I added the poweroff command to qcontrol and run it with the same
result: Short full speed fan, then low fan and pulsing led.

I also noticed that the autopower function cannot be disabled on my
system. When my system is in the state described above and I powercycle
it, it will always turn on, even if I have disabled autopower using

Can anyone explain this? Does powering off work for you other 219 owners?


Reply to: