[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

how to mountloop rootfs to boot debian-arm(hf).img with android bootloader in asus transformer.

Hi, i am working in  debian.arm and debian.armhf images to install in the asus transformer tf101.

I got it working natively installed through nvflash, but there are two kinds of devices, the ones with sbk1 devices nvflashable and the others with sbk2 wich are not, so i've trying now to get working a pseudo-dualboot method by reflashing de boot.img and mount-looping the debian.img as rootfs, but i am kind of stuck.

I've been googling about this but i don't know if everything i tried is obsoleted or if i am missing something.

so, the parameters for the bootload i've added are this:

bootsize = 0x800000
pagesize = 0x800
kerneladdr = 0x10008000
ramdiskaddr = 0x11000000
secondaddr = 0x10f00000
tagsaddr = 0x10000100
name =
cmdline = nvmem=128M@384M mem=1024M@0M vmalloc=128M gpt video=tegrafb console=tty0 usbcore.oldscheme_first=1 lp0_vec=8192@0x1fbed000 root=/dev/loop0 ro quiet splash

And i added  a linuxrc file with this content:


echo INITRD: Trying to mount /dev/mmcblk0p7

mkdir -p /media/data
mount /dev/mmcblk0p7 /media/data

   echo INITRD: Mounted OK
   /bin/losetup /dev/loop0 /media/data/media/debian.img
   exit 0


   echo INITRD: Mount failed
   exit 1


but i get kernel panics unable to mount rootfs.

Making so many tests sometimes i got initramfs busybox shell but i haven't been able to figure out how to do this.

Is there any parameter i've missed in the bootloader? loop=path  parameter may help? if yes how can i set the path? because i don't know if hda or sda applies in this case

is pivot_root another option?

 i've tried also configuring fstab with the image file UUID or setting / for /dev/loop0, how is it supposed to be configured?

Can someone please give me some directions to follow?

Thanks a lot.

P.D:  I am not subscibed to this list so please CC me if someone can help me

Reply to: