[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

armhf build failure for gmime "can't resolve `.rodata' {.rodata section} - `.LPIC21' {*UND* section}"



Hey armhf porters--

henze (the armhf buildd) recently tried to build the gmime 2.6.4-2
package (full logs at [0]), and failed with this error message:

...
/tmp/ccDgDwCh.s: Assembler messages:
/tmp/ccDgDwCh.s:2208: Error: can't resolve `.rodata' {.rodata section} - `.LPIC21' {*UND* section}

It seems to be happening while trying to compile gmime-param.c, not
during linking or anything.

i'm ashamed to say my assembler chops are weak enough that the only
thing this means to me is "there's probably a bug in the toolchain" (and
i'm not even confident about that).

Any suggestions?  

I've tried to log into harris (the armhf porterbox), but the machine
seems overloaded (and/or my debian ssh pubkey is getting rejected).

I don't have armhf hardware of my own to try with, unfortunately.

    --dkg

[0] https://buildd.debian.org/status/fetch.php?pkg=gmime&arch=armhf&ver=2.6.4-2&stamp=1328829285

Attachment: pgpdmwwqrpnJT.pgp
Description: PGP signature


Reply to: