[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

git test failures.

During a rebuild after importing (after importing a new architecture debian rebuilds the packages that were imported) git failed to build on the armhf and s390x buildds with failures in the same tests. Namely "11 among 13 tests" in t9161-git-svn-mergeinfo-push.sh


When something fails in the same way on both armhf and s390x it's generally indicative of a wider problem (since the architectures are very different). So I tried building on amd64 and being lazy I did the build as root. When I did this I got test failures relating to mktemp (unfortunately I didn't save details of these.

I then tried on amd64 as nobody and got failed 7 among 15 tests in t9200-git-cvsexportcommit.sh

I'm not filing a bug right now because I don't know enough about git and it's testsuite to try and make sense of this and file a coherent report but I thought you would appreciate notification of the problem.

Reply to: