[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel 2.6.37 on QNAP TS-419P

Martin Michlmayr wrote:
> * Benoît Knecht <benoit.knecht@fsfe.org> [2011-03-23 12:20]:
> > Now that linux-image-2.6.38-1-kirkwood is out, I tried that one too,
> > but it seems to fail in the same way (there's some disk activity,
> > but then it just hangs and the status led keeps blinking red and
> > green forever).  I'll try to get a serial cable to see what's
> > happening.
> Maybe you ran into #621137.  Can you try again with the latest busybox
> from unstable?  If it still doesn't boot, I can get my TS-419P out
> next week and take a look.

Oh, I'm sorry, I wanted to update this thread last week but somehow kept
delaying it... Bottom line is, it works now, and the problem was btrfs
related (busybox was fine).

Once I got hold of a serial cable, I could see that the boot process
failed during the execution of some initscript that was trying to write
to the disk. It seems that the way of computing when a btrfs filesystem
is full has changed sometime between 2.6.32 and 2.6.37, and so the boot
process was going fine with 2.6.32 (the initscripts could write to the
disk), while it would fail on 2.6.37 and 2.6.38 (because of a "no space
left on device" error).

After copying the system files to a newly formatted btrfs disk, updating
the UUID in the initramfs, and rebooting, everything went fine, and I
was able to selectively copy the rest of my data from the old disk.

Thanks a lot for offering to look into this problem, and sorry it took
me so long to investigate it myself.

Benoît Knecht

Reply to: