[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Squeeze install problems on NSLU2

On 04/07/2011 08:04 PM, brian wrote:
I tried upgrading my SLug to Squeeze using Martin Michlmayr's tarball. I guess everything
went OK (I have installed Debian a few times now). After reboot the SLug goes through the
flashing led things, switches all Leds off except the ethernet led, flashes a few times, the
HDD is accessed a few times and that it, nothing else.

In the past I had this problem with  discrepancies between the flashed data and the partitions
on the HDD, using UUIDS or labels or devices in FSTAB did not fit to what had been flashed.

>> The root partition has to be the 2nd primary partition (i.e. /dev/sdb2 in this example) since the root device is hard-coded in the ramdisk.

If I understand correctly, the bootable partition must be the second one, other than that?

Here is my fstab:

# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/sda2       /               ext2    errors=remount-ro 0       1
#/dev/sda1      /boot           ext2    defaults        0       2
/dev/sda3       /home           ext2    defaults        0       2
/dev/sda4       none            swap    sw              0       0

/boot stuff is all under / after I untarred the tarball.

Here is the ouput from fdisk:

  Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1          12       96358+  83  Linux
/dev/sdc2   *          13         523     4104607+  83  Linux
/dev/sdc3             524       30390   239906677+  83  Linux
/dev/sdc4           30391       30401       88357+  82  Linux swap / Solaris

Disk mounted on another box of course.

Thanks in advance



I got it to work now. I think the problem was the the partitions on the HDD were
not in the correct order. I had corrected them with Fdisk (see the display above)
but probably not written the changes to disk. Later on I saw them out of order
again, so corrected them again, and even wrote them to disk, and it worked.

Thanks to Martin M. for the tarball.

Cheers Brian

Reply to: