[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#594179: dpkg armhf patch acceptance status?

On 18.02.2011 11:13, Guillem Jover wrote:
[ CCing Matthias, as I'd like your opinion on my proposed solution
   involving some Debian gcc changes. ]

The armhf patch for gcc looks ok, however I would like to see this better addressed in Linaro and/or upstream.

  Yes but x86 goes to the other extreme, with separate triplets for
  compatible ABIs ({i386,i486,i586,i686}-linux-gnu); the fact is the
  triplet is not a good ABI specifier.

Sure, but as mentioned above, I'm now convinced the correct solution is
to switch back to i386-linux-gnu.

No, this doesn't work. the triplet currently is set to i586-linux-gnu. Switching back to to i386 would loose the sync primitives and a not working gomp. There is too much relying on >= i586 in many configure's of other packages. Not only for the good, as the switch in Ubuntu to i686 did show, because many configure files assume sse with i686-linux-gnu.


Reply to: