[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Qnap TS-210] don't boot anymore

Hi all,

  I got a Qnap TS-210 last week.  I installed Debian Sid on it 
(with 2x2 TB hdd, RAID-1, ext4) and all was good (rebooted it 3 
or 4 times, copied GBs of data on it, etc.) until Monday evening 
when I asked it to reboot and it got stuck (red/green flashing 
status light, no disk activity).  I tried quite a lot of things 
but I don't have a serial cable.

The short version:
  It can boot in recovery mode (TFTP) with the Debian Installer 
Testing image.  So I can have an ssh console/rescue tool.
  It can't boot on any installed Debian (old one, new one, 
Testing or Sid, ext3 or ext4 (hmm, I realize I always kept the 
RAID-1 though)).

The longer one:
  First, I got the disks out and checked them: they are ok.
(Well, I realized (too long) after I could use the installer as 
a console/rescue tool.  I would have spent less time moving my 
disks around.  Well, I do stupid things like that sometimes.)
  The logs: nothing, it stops logging in /var/log/dmesg after a 
few lines.  Other files are empty (or with no more lines than 
before the reboot).
  I introduced echo lines in some boot scripts (actually, mostly 
in /etc/default/*) to easily track where it stopped.  I thus 
realized that:
  1. It can't write content to files.  It can just create them.
     (That's weird to me.)
  2. It begins executing rcS.d scripts: it loads 
     /etc/default/{console-setup, devpts, ifupdown, keyboard, 
     locale, rcS, tmpfs}.  As it doesn't load bootlogd nor 
     mdadm, I conclude that it stops very early and maybe waits
     for some input.
  At that stage, I tried reinstalling anew.  The installation(s) 
went well, but the installed system didn't boot either.  (First 
with ext4 again, then with only the / partition, in ext3, as I 
thought maybe because it can create files but not populate them 
then it may be related to the file system.  Testing or Sid (but 
they have the same kernels so no real difference).)
  Then, I restored my not-working-anymore-installation (the disk 
part, I did a tarball the first time I got the disks out) and 
tried making a TFTP boot image for it with an older linux-image 
(2.6.32-5-21 instead of -23).  I constructed the initrd from the 
2.6.32-5-23 one, replacing only the modules.  It boots as the 
others: few seconds disk activity then silence and still 
flashing status, no net.
  Then, I installed linux-{image,base}-2.6.35-trunk on my 
installed system from a chroot from the ssh console of the 
installer (I had to force some little things in order to avoid 
error or warning messages).  Same results.

What I haven't tried:
  Reinstalling the Qnap boot image (not really happy with that).
  Not using RAID-1.

Any idea of anything else I can try?

By the way, I'm also looking for a TTL-serial converter (with 
the good connectors or adapters) in France or Europe (French or 
English, and Euros would be better), if you happen to know a  
trustworthy (and not too expensive) retailer...

 Sylvain Sauvage

Reply to: