[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: the mangling of ‘va_list’ has changed in GCC 4.4

On Wed, Jan 27, 2010 at 10:47:55PM +0200, Riku Voipio wrote:
> There is a major problem with gcc 4.4 and armel - the ABI of va_list  
> changed (for c++ libraries). We need to decide one of the following:

What exactly have changed? The ABI (as said in the sentence before) or
the mangling.

> 1) library package name rename (like c2a rename previously)
> - Some hassle for !armel sid users while transition happens

No, this would be a armel-only change.

> 2) binNMU campaign
> - during the upgrade armel sid users packages will be broken (some  
> already are)
> - even after, partial upgrades for armel users risk broken setups

There is no core package affected, so well.

> 3) g++ downgrade or reverting to the old va_list mangling within g++4.4  
> for armel

4) If it is only the mangling, add a compatibility symbol to libstdc++.


Men will always be men -- no matter where they are.
		-- Harry Mudd, "Mudd's Women", stardate 1329.8

Reply to: