[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem went away mysteriously [Re: Bricked my SheevaPlug?]

My new info is at the end of this message. Scroll down to the end. Thanks! to all who replied with suggestions.

So... to recap the story up til now:

On Jun 18, 2009, at 4:46 PM, I wrote:
I needed to move my SheevaPlug to a different part of the lab.

So I logged into the console port.
Issued a "shutdown -h now".
Waited til it said it was shutdown.
Unplugged it.
Moved it.
Plugged it back in.
The little green light comes on, but...
The little blue light never does come on.

I can "connect" to the console port with cu from a close-by Linux box.
But it never says anything.

I've pushed the "reset" thingie with a paperclip (felt a definite click)
but to no avail.  Still no blue light.

it was running fine (Debian Lenny based on Martin's tarball, booting from a 16GB USB stick) before I shut it down...

On Jun 18, 2009, at 5:05 PM, Steve Pirk wrote:
Rick, do you still have the original os on the internal flash? If so, try removing the usb drive and boot. Mine has died twice with corrupt SD or usb memory. Once I get the system up, fdisk does not even see a partition on the external mem.

I replied:
So far as I know, I haven't touched the internal flash. I did try unplugging everything from the USB and SD slots (and the ethernet too, on the off chance) and powering off/resetting. No go. Still only the green light and no response (but with connection) from the console port.

On Jun 18, 2009, at 5:22 PM, Tzafrir Cohen wrote:
How can you tell that you actually connected and got the right terminal
definitions? Did those work before?

I replied:
Well... I do
	cu -s 115200 -l /dev/ttyUSB1
which is what I've always done -- and has always worked before.

cu prints "connected" which indicates that it is seeing the equivalent of what with RS-232 would be DSR asserted (USB is different, I know...) But when I hit <cr> or otherwise bang on the keyboard, I get nothing. I would expect to see "Marvell>>" at least, but... nothing. And no little blue light. Anybody know what turns that on? At what stage of the initialization process should I expect to see it?

On Jun 18, 2009, at 7:28 PM, David Given wrote:
If all else fails you can hook up OpenOCD via USB and reprogram it using the JTAG interface (/dev/ttyUSB0), so don't panic!

Last night I unplugged everything and went home. I got a good night's sleep, and so, apparently, did my little plug. I came in this morning all prepared to do as David had suggested -- reprogram it with the JTAG interface. But before I did that, I tried "one more time" -- plugged it in with the USB stick in the slot and... Lo and behold! The blue light came on! So I plugged in the ethernet and all the other peripherals and hit the reset. It's up and running just fine right now as I type.

So -- A lesson learned. Your SheevaPlug may not come back up after a short power outage. If this happens, letting it sit without power over night may bring it back to life.

Is this a general phenomenon?  Has anybody seen it before?

If it's not just peculiar to my machine... unless the engineers at Marvell can diagnose and fix this particular glitch, I wouldn't plan on using a SheevaPlug for anything mission-critical.

Thanks for all the help!


Reply to: