[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2 Disks (by label/UUID)

On Fri, Apr 25, 2008 at 3:55 AM, Martin Michlmayr <tbm@cyrius.com> wrote:
> * Stuart Read <stuart.t.read+NSLU2@gmail.com> [2008-04-20 22:40]:
> > 1) Why does the troubleshooting page on the wiki say that the UUID
>  > method there is no good when that's the method suggested on this list
>  > by Martin M. et al?
>  I'm offline right now, so I cannot check what the troubleshooting page
>  says.  But essentially, putting UUID or LABEL in /etc/fstab is the
>  only method that's supported at the moment.

Sorry for the delay in responding, haven't had a chance to work on this.
I've now tried both, and neither seem to work.

>  > 2) After updating the flash, the NSLU2 failed to boot (orange LED) so
>  > I had to restore my old fstab and flash to get it booting again. Is
>  > there a step besides updating fstab, creating a new initramfs, and
>  > flashing it?
>  >  I noticed that in /etc/initramfs-tools/conf.d there is a file named
>  > "resume" which references /dev/sda5 (which is the swap). Could this be
>  > the problem?
>  Interesting obversation.  In any case, I always recommend that people
>  moving to UUID in /etc/fstab make the change and then boot with only
>  _one_ disk attached.  If this works but then it fails with 2 disks,
>  maybe the "resume" reference is a problem (although I'm not sure
>  because suspend/resume is not used on the NSLU2).  However, some
>  people report that simply making the UUID change and booting with one
>  disk doesn't work... and I've no idea why because this definitely
>  should work (and works for me).
>  So, can you make the UUID change again and boot with one disk?  Does
>  that work?

All the tests I did were with only the one disk, this started when I
was trying to be proactive and avoid the 2nd disk problem before it

I was very careful with the UUID this time, but still no luck.

In the interest of completeness, after this failure I restored the
system to it's previous state and ran an upgrade (since I had yet to
install the most recent kernel/initramfs) in case this problem had
been fixed by an update. However, the upgrade failed with the

Reading package lists... Error!
E: Malformed 3rd word in the Status line
E: Error occurred while processing initramfs-tools (UsePackage2)
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.

At this point I'm not sure how to proceed...I've probably made things
more complicated but I'm not sure whether or not to reattempt the

> --
>  Martin Michlmayr
>  http://www.cyrius.com/

Thanks all,

Reply to: