[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Broken hardware?

I was running Debian on an NSLU2 quite happily until today when it seemed to suddenly stop working. This was with a 2GB flash drive as root, and a large hard disk connected via a USB hub. System had worked flawlessly for a couple of years until now. When I checked it had only one light on and refused to boot, with a 'strange' light sequence (top light amber, second light green, then top light would go out, then after a bit the second light would go, and the top light would relight amber. The second light would go green and the sequence would repeat).

No big deal - I figured I'd check the flash drive on a laptop and repair if necessary. There were some problems reported as fixed which seemed to mean dumping everything in /lost+found... not good. Reinstall time - not a problem, I've done this a few times. I can flash the installer image easily enough, however I can't get the slug to boot with a USB device attached. With just the flash drive attached it seems to go through a fair amount of the boot process, the top light always remains orange though, and the second light is green. After a minute or so through this 'process' then all the lights flash in a sequence going 'down' and it seems the device reboots... With two devices attached then it goes through the shorter repeat sequence described in the first paragraph :(

With no USB devices attached it does get to the Debian installer screen, but clearly this is no good to me with no USB devices attached. If I attach a device at this point I lose connectivity and the NSLU2 reboots again. I've even tried the manual installation method of creating the filesystem on a Linux system and untarring a pre-created image to this filesystem. But it fails also.

So, I think I'm looking at broken hardware - something has just failed... anyone care to offer thoughts/confirmation?

Thanks in advance,

Reply to: