[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upslug2 hanging, indicating "timeout occurred"

On Sun 2007-12-02 05:04:28 -0500, Rod Whitby wrote:

> What's between the PC and the NSLU2?  Any routers or s/w firewalls
> which might be filtering the non-IP ethernet protocol that the
> NSLU2's upgrade mode uses?

This happens even when the only thing between the two machines is an
ethernet cable, unfortunately (with link light on both sides, so it's
not a crossover cable issue).  The PC's iptables were set to default
policy ACCEPT on all tables.  And *some* packets are getting through,
anyway: at least enough packets to trigger the erase sequence.

You inspired me to break out tcpdump to try to record what was
actually going out on the wire, though.  I just hooked up my system
via the exact same cables (ethernet and serial) as last night, and ran

[0 root@monkey ~]# tcpdump -s0 -w /tmp/igor.upgrade.pcap -i 3com

and then kicked off the exact same upslug2 run.  And this time it went
through!  Maybe putting the interface in promiscuous mode helped?
maybe it was putting monkey to sleep and waking it up?  I don't know.
At any rate, the same upslug2 procedure that i'd tried and failed
about a dozen times last night time worked this morning.



Attachment: pgpG1bosw9gBz.pgp
Description: PGP signature

Reply to: