[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Upgrade reflashed without ixp400 driver

Hi Martin / Marc!

You're right it was 0.10+r58-4. The /etc/mkinitramfs/nslu2.conf says
NSLU2_IXP400_REQUIRED=true so the check seems to be broken.

I kept a screenshot:

Unpacking replacement slugimage ...
Preparing to replace nslu2-utils 0.10+r58-3 (using
.../nslu2-utils_0.10+r58-4_arm.deb) ...
Unpacking replacement nslu2-utils ...
Setting up libklibc (1.4.11-3) ...
Setting up klibc-utils (1.4.11-3) ...
Setting up libtiff4 (3.8.2-6) ...

Setting up slugimage (0.10+r58-4) ...
Setting up nslu2-utils (0.10+r58-4) ...
update-initramfs: Generating /boot/initrd.img-2.6.16-2-nslu2
Warning: ixp400_eth ethernet driver not found, not included on image
Error: This system has the ixp400_eth module loaded;
not creating initramfs image that does not contain the module.

To force creation of an image without the module, set
NSLU2_IXP400_REQUIRED=false in /etc/mkinitramfs/nslu2.conf
Flashing initramfs: done.
Flashing kernel: done.

Do you want to erase any previously downloaded .deb files? [Y/n]
Press enter to continue.


Now it seems to me like this is a bug in nslu2-utils. Of course it was a wrong
assumption that the next kernel version would fix it. I'm filing a bug report
against nslu2-utils now.


http://www.amazon.de/gp/registry/wishlist/1STJFWXVXM083/  ICQ#75570407

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: